0

I have trident X F3-2400C10D-16GTX (2x8GB). When i open my pc, the auto-mode is on 1066 MHz. I change it from bios (also the latency) but it doesn't boot after it and the Dram Led is red. So to boot I press the MemOK button and everything is back to default. I also tried the XMP profile but it had the same result. (The CPU is Intel 4790K)

5
  • First Step; Update the UEFI firmware to the current revision.
    – Ramhound
    Oct 2, 2014 at 17:54
  • Try each RAM stick by itself, one at a time. Any difference? Did this RAM ever work right in this machine? Oct 2, 2014 at 18:46
  • If i try one at a time it runs XMP without a problem, at 2400MHz. So the memory isn't broken. But when I try them together the pc doesn't boot. No the pc is new, and the memory only have worked on 1066 MHz.
    – m0ur
    Oct 2, 2014 at 18:54
  • @jim_f - If its already updated to the latest version, then, you already did it
    – Ramhound
    Oct 2, 2014 at 19:04
  • OK, so what is the next step?
    – m0ur
    Oct 2, 2014 at 19:07

1 Answer 1

0

If i try one at a time it runs XMP without a problem, at 2400MHz. But when I try them together the pc doesn't boot

This tells me that there is a timing issue between the RAM sticks then. Either one/both or the RAM sticks are faulty, or you board has timing issues or is incompatible with the RAM form some reason.

If updating it to the newest BIOS/EFI doesn't help, then you'll need to try new RAM sticks (to rule out faulty RAM), and if they behave the same way, you need to try a new motherboard (to rule out faulty motherboard). If it still happens, then you need to try a different brand of RAM (to rule out compatibility issues).

I had a similar problem back in the day with Kinston's HyperX RAM. One at a time was fine, but two or more couldn't keep timing between the sticks properly. Went thru two sets of 4 sticks and a couple new motherboards, in lots of different combinations. Then tried 4 sticks of Kinston's "Value RAM" instead and they ran perfect, and have for the last 6+ years.

Anyhow, yeah, welcome to building PCs, you need spare parts for testing and troubleshooting.

4
  • Thanks for helping. I have tried my ram at another motherboard and it runs fine at 2400. Probably the motherboard is faulty because another memory I tried it ran at 1066,and also didn't boot when I tried to change it to 1600. But it seems to me very strange because the motherboard is new. I bought it a month ago.
    – m0ur
    Oct 2, 2014 at 19:59
  • Trust me, after well over a decade of building computers - new hardware is often broken/faulty. :) Oct 2, 2014 at 20:05
  • Hmm that's not good news. So you suggest me to try something with the warranty..
    – m0ur
    Oct 2, 2014 at 20:10
  • Yup, take it back where you got it and get them to exchange it. If they won't warranty it from some reason, then you'll have to contact the manufacturer and request an RMA (Return Merchandise Authorization) to start the in-warranty replacement processes. Oct 2, 2014 at 20:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .