1

Don't ask me how she did this... witchcraft probably.

When I check her Google Nexus device, I can see the google location service is using 'Malta' as it's location, even though the device's location detection is set to use 'fine' (i.e. use GPS, wifi and mobile networks). This is bizare, I can't see any way to tell it we're in the UK.

What's even more bizare is on her PC, when we use either Chrome or Firefox to go to google.com it suggests we switch the language to Malti. Clearly something has associated both devices to that country.

I have tried signing her out of google Chrome, clearing the cache (all the private data) and no joy. The only thing running on both devices that might possibly be using some sort of google location service is the google drive software but I see no way to set location in that.

I am stumped. This is nuts. Anyone got any idea how I can fix this for her. I should probably mention I've been to the same places with my Android phone, used my gmail quite happily and neither my phone nor my home laptop thinks I'm in another country now that I'm in the UK. I think the only real difference is that she uses google drive, sometimes, although not on holiday in Malta.

  • maps.google.com/locationhistory/b/0 may be of use in working out where exactly google thinks she is – Journeyman Geek Oct 4 '14 at 11:36
  • There's no recorded history. – user630574 Oct 4 '14 at 13:54
  • @user630574: Perhaps she has configured the devices to use a proxy server in Malta? Check your network settings. Also, have you checked the Region settings in the Windows control panel? – James P Oct 4 '14 at 14:19
  • No, she added a network connection for the flat in Malta, which I've now told it to forget but that wasn't the network being used. Everything is set up as normal (connected to my local wireless). It's not a windows region issue because it affects her Nexus device too, which runs Android. Pretty sure this is a Google account problem, I just can't seem to find where the problem is. – user630574 Oct 4 '14 at 14:26
  • Try going to Google Maps on her Nexus then bring up Settings from the menu that you can swipe from the left. Click the Edit Home or Work option and put in your current location. – James P Oct 4 '14 at 14:46
2

All these devices use google's settings.

To restore it, do the following:

  1. Go to google.com.
  2. Click on the gear in the top-right corner.
  3. Click Search Settings.
  4. On the settings page, next to Location, remove everything, so its blank.
  5. Save settings. Problem should be fixed now.

enter image description here

  • What gear? You mean on her Nexus or PC? – user630574 Oct 4 '14 at 12:32
  • 1
    Presumably the gear at google.com, look at the top right corner of the page. Any device whatsoever. – sourcejedi Oct 4 '14 at 13:14
  • 1
    Open an internet browser on any device, a pc for example. Then navigate to the website google.com. Make sure you are logged in so you can see the settings icon (gear) at the top right. – LPChip Oct 4 '14 at 13:36
  • Actually, if I go specifically to google.com there is a gear but when I try to change the location it tells me that's not a valid malta address. Reason being, it keeps redirecting me to google.com.mt! I can't get it to stop doing that. There's nothing in the local though. – user630574 Oct 4 '14 at 13:55
  • I just added a screenshot of the gear, but you seem to have replied finding it already. Can you try using the google.com.mt site to change it there? – LPChip Oct 4 '14 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.