1

Compiz is causing weird flickering. It's a bit difficult to describe, but when I move my mouse over CCSM:s UI elements for example, or even just browse with firefox, the screen updates often don't happen immediately. Then shortly after, the screen updates, but with a buffer that should've been shown earlier. It's as if the buffer update is always happening a few steps later than it should.

Another example; I was trying to edit a text file in nano in a terminal. Scrolling down in nano sometimes appeared to scroll up, until I scrolled down more, at which point nano appeared to scroll where it was supposed to scroll the first time. The glitching is only visual, applications still work as they should, but the UI feedback doesn't thus immediately reflect changes, but instead flickers.

Here's a video of how it looks like: https://www.youtube.com/watch?v=1gTkBStGcyE

However, if I rotate the desktop cube or use the zooming function, the flickering disappears. It seems like it only happens when the screen isn't transformed.

I've tried disabling individual Compiz plugins one at a time, but that didn't seem to help. I also tried enabling and disabling the individual options in CCSM's OpenGL and workarounds sections, to no avail.

I also tried switching off buffer flipping in NVidia X server settings. This seemed to fix the problem at first, but soon I noticed that UI elements which were previously in a focused state, appeared to retain their focused state. Ie. many elements appeared to be focused at the same time.

Disabling Compiz' Copy to texture plugin also seemed to alleviate the flickering, but then I noticed that some repaints just weren't happening, or happened with a delay along with a later repaint.

Don't know what else to try. All suggestions welcome!

System specs:

  • Lubuntu 14.04
  • LXDE
  • Compiz 0.9.11.2
  • NVidia's proprietary driver v. 343.22.
  • GeForce GTX 560 Ti
2

There is a known bug in compiz causing the issue. NVIDIA engineers have provided a patch but for legal reasons on Canonical's side it hasn't been included in Ubuntu's distribution of compiz yet.

Christopher Townsend is graciously providing a PPA with the patched compiz. It is available here: https://launchpad.net/~townsend/+archive/ubuntu/compiz-nvidia-refresh-test

It's a good workaround until the patch gets accepted, but any compiz updates coming from Canonical will overwrite the patched version, so you might want to lock the compiz package in Synaptic.

The corresponding Launchpad bug for the issue is being tracked here: https://bugs.launchpad.net/compiz/+bug/1288747

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.