86

I'm running Windows 7, and I've been experiencing high memory usage from one of my svchost.exe processes.

svchost high memory

Services under that particular process are BITS, EAPHost, IKEEXT, LanmanServer, MMCSS, ProfSVC, RasMan, Schedule, SENS, SharedAccess, ShellHWDetection, Themes, winmgmt and wuauserv.

I've been able to narrow it down to a specific service by separating each services into its own process and identified wuauserv as the cause.

Stopping the Windows update service(wuauserv) stops the insane memory usage but that's not a solution.

Any help please?

I've have already tried re-naming the SoftwareDistribution folder and re-registering the Windows Update Agent. Nothing has worked so far.

  • 1
    What do you mean memory leak? Is the RAM not released after you kill processes? My understanding was that svchost combines multiple services so they take less resources overall. Windows 7 manages resources by keeping them available to itself e.g. – Raystafarian Oct 5 '14 at 9:36
  • this is normal. The service must handle a lot of update data. My usage is during setup of updates also several hundred MB. – magicandre1981 Oct 5 '14 at 17:15
  • 1
    Oliver, did you manage to solve it? If so - how? – Oz Edri Oct 17 '15 at 21:26
  • 1
    Have you checked this question: superuser.com/questions/951960/… ? I'd recommend stop the automatic updates and run that on demand – elachell Aug 10 '16 at 21:57
  • This is still happens in Windows 10 – ravi parekh Dec 25 '16 at 8:49
60

In my experience, when wuauserv starts eating memory, the best thing to do is to wait until it finishes installing the updates and then reboot.

If you can't or aren't willing to reboot now, you can always reset wuauserv with the following BAT script (right click & run as administrator):

net stop wuauserv
net stop bits
rd /s /q %windir%\softwaredistribution
net start bits
net start wuauserv
wuauclt.exe /detectnow

Hope it helps.

  • 2
    On my computer, windows update hogs almost 2GB immediately after each reboot. Restarting the windows update service worked for me though. Thanks! – CrouZ Apr 22 '15 at 14:30
  • stopping that windows update service did indeed help. Thanks! – Chani May 27 '15 at 12:11
  • 5
    you can always reset wuauserv with the following BAT script For the record, it's either (.)BAT file or batch script (or batch file), not BAT script which sounds more like a script for The Bat!. – Synetech Jul 3 '15 at 6:51
  • According to blackmanticore.com/30becce9a227e690c0ae63bedc26c9be del /s /q %windir%\softwaredistribution\download\*.* & for /d %i in (%windir%\softwaredistribution\download\*.*) do rd /s /q %i would be a safer bet – Ross Smith II Nov 26 '16 at 15:24
48

An update to fix the issue has been rolled out:

Please see KB3050265

  • 2
    Thanks! This seems to have fixed the problem. Now my mom's old computer with 2 GB of RAM, on which I recently installed Windows 7 due to XP's end-of-service, is usable again. – bcody Jul 11 '15 at 13:27
  • 2
    You literally saved my laptop, bro! – Wok Jul 13 '15 at 13:19
  • 6
    I haven't tested KB3050265, but KB3102810 worked for me. superuser.com/a/997067/433287 links to a recent (11/3/2015) patch that worked for me on 2 separate machines. – aoetalks Nov 11 '15 at 21:23
  • 2
    I already had KB3050265 installed. KB3102810 worked for me. – JumpingJezza Dec 16 '15 at 10:25
  • 1
    Neither KB3050265 nor KB3102810 fixed the issue for me. The only way to address it was to disable updates in Control Panel -> Windows Update -> Change Settings. Then once a month, manually enable them after 2nd Tuesday, sit through this 100% CPU usage or better go get a meal while it installs everything and then disable updates again & repeat. Otherwise if you keep it on, the wuauserv service may kick in whenever it wants and halt your system down to a crawl. Too bad that Microsoft can't fix this for over a year that this issue has been out! – c00000fd Jan 17 '16 at 1:26
2

I don't know if you still have this issue but I had something similar in Windows 8. I had data transfer of several hundred MB per day and using NetBalancer identified the issue as the Windows update service (wuaserv) so I disabled it and then ran the MS Fixit option for Windows update. I think there is one for Windows 7 here but do check it is compatible before you run it.

http://windows.microsoft.com/en-gb/windows/troubleshoot-problems-installing-updates#1TC=windows-7

Although its early days I have turned automatic updates back on and so far so good. At least I know what to stop if the problem comes back again. The NetBalancer program was a great help in identifying the problem.

Hopefully you have already solved it, if not this might be worth a try.

2

I found the following article: https://social.technet.microsoft.com/Forums/windows/en-US/4a782e40-bbd8-40b7-869d-68e3dfd1a5b4/windows-update-scan-high-memory-usage?forum=w7itproperf&prof=required

I think microsoft did something in the mid of 2014 - this post also starts in Nov 2014, yours in Oct 2014...

We have this issue too at a customer with about 60 PCs... we had to disable the Windows Update service for now. Official answer from microsoft is pending, hopefully the give us a patch sometime...

  • I have this problem on a computer unused since 2013. However, I had to download a new version of Windows Update before searching for updates ( answers.microsoft.com/fr-fr/windows/forum/… ). The problem might come from this new version of Windows Update, which might have been released in 2014. – Wok Jul 13 '15 at 10:19
0

svchost.exe is used as a common system process, some malware often uses a process name of "svchost.exe" to disguise itself. The original system file svchost.exe is located in C:\Windows\System32 folder. Any file named "svchost.exe" located in any other folder can be considered as malware

  • 1
    Not this time. According to description it is about wuauserv involved in the process and it is a common Microsoft bug as usual. – Dee Jul 12 '16 at 12:22

protected by Community Sep 17 '15 at 18:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.