So since maybe a week or so, my the fonts on certain websites are looking rather off... They're jagged and often bigger than they used to be.

As an example, here’s the same page in both Chrome and Firefox (note: that the Chrome page used to look like the Firefox page):

Click for full size

Click for full size

As you can see (hopefully), the font in Firefox is much crisper. And it’s not just this website that doesn’t work properly, there are several others (yet not all, which is weird).

Anybody know how to fix this? I'd rather not switch browsers.

EDIT: Browser version is 31.0.1650.63 m

EDIT: Things I already tried: Resetting to default settings; Trying to enable/disable Direct Write (option isnt available in the list); Adding "/high-dpi-support=1 /force-device-scale-factor=1" to executable


13 Answers 13


On Windows 10 & Chrome version 52 I could not find any "DirectWrite" option in the experiments tab.

However, I was able to resolve the issue by disabling a different experiment:

Set "Accelerated 2D Canvas" to "Disabled"

(In the browser's address bar, go to chrome://flags#disable-accelerated-2d-canvas, change the setting, relaunch the browser.)

Since the fix for this issue has clearly changed, I would suggest in general turning off any hardware-accelerated text-rendering/2D-rendering features in the future if this fix stops working.

On Google Chrome 55, this issue appears to have cropped up again. As anticipated, the fix was disabling hardware acceleration, it just changed locations.

The new fix (for me) appears to be:

Settings -> Show advanced settings... -> System
UNCHECK "Use hardware acceleration when available"
  • 2
    GDI rendering has been removed from Chrome for Windows as of version 52, so the option to disable DirectWrite has been removed. Aug 10, 2016 at 17:09
  • Bummer, didn't work for me either. (Windows 7, Chrome 52, regular zoom. The obsolete DirectWrite option did do the trick for me in older versions of Chrome.)
    – Arjan
    Aug 15, 2016 at 6:48
  • For future reference, as for the removal of GDI: bugs.chromium.org/p/chromium/issues/detail?id=579678
    – Arjan
    Aug 15, 2016 at 6:59
  • Worked for me today. Chrome fonts weren't displaying correctly as of about a week ago. Perhaps a NVidia graphics driver update screwed with this?
    – Phlucious
    Sep 13, 2016 at 17:53
  • @Phlucious I have intel graphics drivers, so I don't think it's an Nvidia issue.
    – mrswadge
    Nov 30, 2016 at 15:18

This worked for me:

  1. Open Google Chrome
  2. Open a new tab and enter the following in the address bar: chrome://flags/#disable-direct-write
  3. Click "enable" to enable this switch, disabling the use of Microsoft DirectWrite by Google Chrome.
  4. Close and re-open Chrome.

Easiest fix I have seen for Chrome v53 is to enable 2G for web font loading - chrome://flags/#enable-webfonts-intervention-v2

New version of User Agent Intervention for WebFonts loading. Mac, Windows, Linux, Chrome OS, Android Enable New version of User Agent Intervention for WebFonts loading. #enable-webfonts-intervention-v2


  • Thanks, this worked for me, as did this solution superuser.com/a/1112095/155435. I was then able to revert all settings to default and it appeared to still be okay.
    – mrswadge
    Nov 30, 2016 at 15:22
  • This also worked for me. Note: I had to disable the "accelerated 2d canvas" and "Use hardware acceleration when available" settings. Feb 15, 2017 at 15:29

When Chrome is running, right click the Chrome icon in the task bar. Then right-click the line that reads "Google Chrome" in the grey area, click "Properties". Go to "Compatibility" tab. And check the entry in the lower half that says "Disable display scaling on high DPI settings".

This is due to a current problem with Chrome's font scaling if Windows' font/content scaling feature is activated (i.e. if you have a high resolution / big screen and set Windows to make things bigger so that you can actually read them).

  • Odd. I take you closed all instances of Chrome after you did that and then started Chrome anew, right? Also check in task manager that no other instance is running - or log out and back in. Also you DO use DPI scaling in Windows, don't you? (Because I had the exact same issue) Oct 5, 2014 at 13:47
  • My DPI scaling is set to the default 100%
    – Cleverbird
    Oct 5, 2014 at 16:06
  • Ah, okay, that changes the picture... try opening this URL in Chrome and clicking 'enable' - then relaunch chrome (on the bottom there is a button for that): chrome://flags/#disable-direct-write ...also please edit your original post and list what you've already done. Oct 5, 2014 at 18:02
  • I dont have anything called "Direct write" or "DirectWrite" in those options. Changed my original post to reflect the things I tried.
    – Cleverbird
    Oct 5, 2014 at 21:13

Fixed it! Apparently my Chrome was no longer updating for whatever reason... I managed to fix it with the help of the following link:


ADDENDUM: Chrome version 53 had this issue with fonts. The issue was fixed in version 54. Fixing the failed auto-update function allowed the actual fix for the poor font quality issue.


In my case (Chrome 58 on Windows 10) I did following: I first went to:


And Founnd the option titled:

UI Layout for the browser's top chrome Mac, Windows, Linux, Chrome OS

Then selected Normal from corresponding drop-down and restarted Chrome.

The problem solved.


Windows Registry editing fixed the font thickness issue for me completely, we can tune the font thicknes/darkness by calibrating FONTSMOOTHINGGAMMA value to between 150 and 190 hexadecimal( 336 to 400 decimal )

  • search for FONTSMOOTHINGGAMMA by keying "Ctrl F" ( will automatically take us to CurrentUser\ControlPanel\Desktop path)
  • right-click mouse on FONTSMOOTHINGGAMMA on the rightside, Modify... enter any thing between 150 and 190 hexadecimal. (the Lower the value, the thicker the fonts.)
  • close the REGEDIT tool
  • LOGOFF and then LOGON

Now all the fonts are very thick & very dark in Chrome Browser.

But we must make sure that ClearType smoothing is enabled in Windows ( controlPanel -> personalization -> appearance -> Effects -> ClearType smooth check (ticked box) )

                     OR  alternately in RegEdit ...



I encountered the same poor-font-rendering issue immediately after making a system tweak. Undoing the tweak corrected the rendering issue. In an attempt to speed up my machine, I modified System Properties/Advanced/Performance to adjust for best performance, which disabled "Smooth edges of screen fonts." When that option was re-enabled, the font rendering issue disappeared.


For me it was simply monitor settings. I use a HDTV as my monitor, and it was using a preset that worked fine for gaming, but the contrast, brightness, and other settings made text look like it was being anti-aliased wrong. Simply changing to a different preset fixed it for me.


Resetting all flags to default did it for me.


chrome//:flags and disable "LCD Text Antialiasing"

  • If you read the actual answers you will see this was a specific issue with a specific version of Chrome, and that the question was answered 2 years ago. Your answer is a good answer, just not for this question. Jan 5, 2017 at 0:46

I had the same problem as well, what fixed it for me was the following: When you install anything from Adobe, it will install the Creative Cloud application. Open this app, go to "elements", "fonts" and disable all synced fonts.


I fixed it by turning on ClearType text in my Windows 7 Display properties.

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .