I have some hard drives (IDE) from my old PC and I need the files that are on it to put onto my new PC. My new PC has a SATA drive and it's an All-in-One HP PC.

I bought an External Enclosure for Hard Disk (the brand is Connectland). I would have bought a better brand but there isn't really much in the way of computer supplies near where I live.

On the box, it says it supports:

  1. USB 2.0
  2. 3.5"
  3. SATA
  4. IDE

Most of the Connectland's web pages are in another language. Even if I click on the English flag to show the English version, only certain web pages (the useless ones) are in English.

2 of my old drives are IDE, and 1 is SATA.

There is no support on the Connectland website and no drivers etc are available for download from the Connectland website.

When I put the IDE drives in and power it on and plug it in nothing happens. The drive can't be seen in Windows/File Explorer. When I go to Device Manager there is an exclamation (the yellow icon) next to it. When I go to Disk Management it does not appear.

If I right click Disk Management in the treeview, and select Rescan or Refresh, it still doesn't show that IDE drive.

I've right clicked it in Device Manager and selected Update Drivers but it (as usual) says I already have the latest drivers installed.

The old SATA drive works perfectly with the enclosure. But none of the IDE drives work. Windows cannot recognize them.

Formatting them is not an option because: 1. I need the data that's on them! and; 2. I can't see them anywhere on the PC! So I can't format them!

I've searched tirelessly but have come up empty handed.

Does anybody know why this won't work for me? Or how I can fix it?

I don't know if this is relevant or not but I think it's an important connection:

My current PC has a Sata drive. Old sats drives that I put into the enclosure appear and work perfectly on my current PC. But IDE drives are not recognized.

Note: While Windows is starting up I can press F9 and it will allow me to see all drives that I can boot from. It shows the IDE drive in the Legacy boot list BUT I can't boot from it it's just a disk with lots of files (no operating system on it).

I can also change a setting in BIOS from ACHI (I think that's what it was) to IDE but then I can't boot into windows on my internal, primary drive which means I still can't access the drive in the enclosure. How do I get around this? This enclosure says I can put IDE and SATA drives in it and my current PC has an internal SATA drive, but only SATA drives that are in the enclosure are being recognized by windows!

Please help.

  • Have you in any way looked at the jumper settings on the IDE drives? Better put them on "master" setting, or - if that doesn't work - cable select (CSEL). Mostly the jumpers are at the back and the drive contains a sticker on how to configure the drives. – Maarten Bodewes Oct 5 '14 at 13:06
  • By the way, USB-2.0 will require lot of waiting. It will max at 40 MB/s and it has huge latency issues (so don't mix copy commands, and beware of small files slowing down your transfer to near nothing at all - possibly first zip them on the other computer). USB-3 would have up to 4 times faster. – Maarten Bodewes Oct 5 '14 at 13:10
  • 1
    @owlstead OMG OMG OMG OMG OMG OMG OMG! IT'S WORKING! THANK YOU!!!!!!!!!!!!!!!!!!! :-D – jay_t55 Oct 5 '14 at 14:29
  • 1
    @owlstead Sorry about the delay, I got distracted copying my old C# projects over to my new drive. The winning jumper setting was Cable Select :D – jay_t55 Oct 5 '14 at 14:43
  • 1
    For the benefit of other readers with a similar problem, you don't need to mess with drivers for external hard drive enclosures or adapters if your version of Windows is later than 98. They are built into Windows. – fixer1234 Oct 5 '14 at 15:14

According to the unmissable comment from jay in the comments, I guess the answer is to set the jumpers correctly on the IDE drive. "Cable select" should just work, but if it doesn't try to set it to "Master" instead.

If it still doesn't work, you may want to take a good look at the partitions on the drive using GParted or another partition tool to see if the partition information is intact.

  • Just incase somebody skips the comments up the top, the setting that worked for me was Cable Select. – jay_t55 Oct 5 '14 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.