1

Been going round in circles for this for days now and i'm really stuck.

My ftp had been working fine through filezilla, and through the ftp interface in PHP Storm

Then all of a sudden the next day i can get directory listings, the FTP just times out.

MY windows firewall is OFF My antivirus is OFF My Routers Firewall is OFF

I have detected the problem is not with my router, by removing the router and connecting directly to my dsl modem.

My FTP clients are set to passive mode, as it always has been.

I tried downloading fire-ftp, cute-ftp, core-ftp

Same with all of them can't connect.

Now heres the thing, i booted up Dreamweaver 5 and tried to connect same problem timeout on directory listing.

Then i checked the checkbox for use IPV6 (previously dreamweaver had always failed to connect with this option checked) And hey presto i can ftp through dreamweaver.

This made me think that somehow Windows is Using IPV6 as default.

I tried to disable IPV6 Completely by checking off the IPV6 checkbox on all my adaptors.

And by editing the registry to disable IPV6 (see article here)

Still couldn't connect in any of my dedicated FTP programs. I can still connect in dreamweaver with the IPV6 checkbox clicked.

I've since removed the registry entry i added above and turned IPV6 back on on all my adaptors

So if anyone can help me i would be so thankful, I'm a web developer and not being able to use FTP Clients is a severe issue for me.

This is the log from filezilla:

10:10:00    Status: Resolving address of c*r*l*n*n*l*o*.c*.u*
10:10:00    Status: Connecting to ***.***.***.***:21...
10:10:00    Status: Connection established, waiting for welcome message...
10:10:00    Response:   220 FTP Server ready.
10:10:00    Command:    USER *************
10:10:00    Response:   331 Password required for ************
10:10:00    Command:    PASS ********
10:10:00    Response:   230 User ************ logged in
10:10:00    Command:    OPTS UTF8 ON
10:10:00    Response:   200 UTF8 set to on
10:10:00    Status: Connected
10:10:00    Status: Retrieving directory listing...
10:10:00    Command:    CWD /
10:10:00    Response:   250 CWD command successful
10:10:00    Command:    TYPE I
10:10:00    Response:   200 Type set to I
10:10:00    Command:    PASV
10:10:20    Error:  Connection timed out
10:10:20    Error:  Failed to retrieve directory listing

This is the log from dreamweaver:

  < 220 FTP Server ready.
 > USER u36384919-havelock
 < 331 Password required for ************
 > PASS
 < 230 User ************ logged in
 > PWD
 < 257 "/" is the current directory
 > CWD /
 < 250 CWD command successful
 > CWD /
 < 250 CWD command successful
 > EPSV
 < 229 Entering Extended Passive Mode (|||63601|)
 > TYPE A
 < 200 Type set to A
 > LIST
 < 150 Opening ASCII mode data connection for file list
 < drwxr-xr-x   5 ************ ftpusers     4096 Oct  6 09:48 .
 < drwxr-xr-x   5 ************ ftpusers     4096 Oct  6 09:48 ..
 < -rw----r--   1 ************ ftpusers     7342 Sep 22 22:03 .htaccess
 < -rw----r--   1 ************ ftpusers      418 Sep 25  2013 index.php
 < -rw----r--   1 ************ ftpusers    19929 Nov 26  2012 license.txt
 < -rw----r--   1 ************ ftpusers     2447 Nov 13  2010 postinfo.html
 < -rw----r--   1 ************ ftpusers     7185 Aug  6 18:27 readme.html
 < -rw----r--   1 ************ ftpusers     2656 Nov 14  2010 screen.css
 < -rw----r--   1 ************ ftpusers     4892 Oct  4  2013 wp-activate.php
 < drwxr-xr-x   9 ************ ftpusers     4096 Sep 22 19:21 wp-admin
 < -rw----r--   1 ************ ftpusers     1354 Nov 26  2012 wp-app.php
 < -rw----r--   1 ************ ftpusers      220 Mar 29  2012 wp-atom.php
 < -rw----r--   1 ************ ftpusers      271 Jan  8  2012 wp-blog-header.php
 < -rw----r--   1 ************ ftpusers     4795 Sep  6  2013 wp-comments-post.php
 < -rw----r--   1 ************ ftpusers      238 Mar 29  2012 wp-commentsrss2.php
 < -rw----r--   1 ************ ftpusers     3087 Oct 24  2013 wp-config-sample.php
 < -rw----r--   1 ************ ftpusers     3383 Sep 22 17:09 wp-config.php
 < drwxr-xr-x   9 ************ ftpusers      120 Oct  2 13:24 wp-content
 < -rw----r--   1 ************ ftpusers    2932 Sep 25  2013 wp-cron.php
 < -rw----r--   1 ************ ftpusers     240 Mar 29  2012 wp-feed.php
 < drwxr-xr-x  12 ************ ftpusers     4096 Sep 22 20:16 wp-includes
 < -rw----r--   1 ************ ftpusers     2380 Oct 24  2013 wp-links-opml.php
 < -rw----r--   1 ************ ftpusers     2359 Oct 24  2013 wp-load.php
 < -rw----r--   1 ************ ftpusers    32645 Aug  6 06:38 wp-login.php
 < -rw----r--   1 ************ ftpusers     8235 Nov 13  2013 wp-mail.php
 < -rw----r--   1 ************ ftpusers      413 Apr  3  2012 wp-pass.php
 < -rw----r--   1 ************ ftpusers      218 Mar 29  2012 wp-rdf.php
 < -rw----r--   1 ************ ftpusers      334 Apr  3  2012 wp-register.php
 < -rw----r--   1 ************ ftpusers      218 Mar 29  2012 wp-rss.php
 < -rw----r--   1 ************ ftpusers      220 Mar 29  2012 wp-rss2.php
 < -rw----r--   1 ************ ftpusers    10880 Nov  4  2013 wp-settings.php
 < -rw----r--   1 ************ ftpusers    25665 Nov 13  2013 wp-signup.php
 < -rw----r--   1 ************ ftpusers     4026 Oct 24  2013 wp-trackback.php
 < -rw----r--   1 ************ ftpusers     3015 Oct 25  2013 xmlrpc.php
 < 226 Transfer complete
 > QUIT
 < 221 Goodbye.
  • The title and content is misleading: the timeout occurs after the PASV command, not when requesting the directory listing. – Sander Steffann Oct 6 '14 at 9:19
  • Something is messing with your PASV command. When you enable IPv6 support the client uses EPSV instead which works. As it works when directly connecting to your modem (assuming that it is a real modem) this had to be something on your system. It usually is some 'security' software that causes such problems. Check what is installed and maybe uninstall all of them completely. Disabling might not be enough when they are broken. – Sander Steffann Oct 6 '14 at 9:25
  • Your FileZilla client appears to be trying to get a directory listing before switching to passive mode. Try a different FTP client. – Michael Hampton Oct 7 '14 at 20:51
1

Well i sorted this out eventually.

I removed all the rules from the windows firewall and rebooted.

When I tried the ftp software again i got the windows firewall dialog asking me if i wanted to allow the application i clicked yes and everything started working as normal.

I dont understand why it didn't connect when the firewall was off. Guess thats windows for ya.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.