0

I'm having trouble with my home network, since I've started using a new wireless router.

The setup is a Zyxel VDSL Modem pluged into the wall, and connected to a TP-LINK modem via the ethernet ports.

When I enter 192.168.1.1 - it will either access the modem, or the router, and it seems to switch randomly within seconds.

If I can access the modem, I can access the internet.

If I'm accessing the router, there's no internet available.

Any idea what's causing this?

  • Both devices have the same IP address 192.168.1.1? – DavidPostill Oct 7 '14 at 9:22
  • @DavidPostill I figured 192.168.1.1 was automatically forwarding to the modem. – user1068446 Oct 7 '14 at 9:28
  • 1
    What's the model of the TP-Link device? – happy_soil Oct 7 '14 at 9:50
1

It seems that both devices are having the IP address 192.168.1.1, thus the access conflict.

It you are using the TP-Link device just for WLAN access, you can configure it to 192.168.1.2 and disable its own DHCP service.

  • Hey thanks, changing the IP address seemed to resolve my issues. Can you explain what disabling DHCP will do? Also - what actually happens when two devices have the same IP address? – user1068446 Oct 8 '14 at 20:30
  • In Ethernet, the so called MAC addresses (MAC = Media Access Control) are used for computers and routers to find each other. Before your computer can communicate with the router, a message is sent to all devices requesting "who has the IP 192.168.1.1, please reply with MAC address". If two devices have the same IP, they both answer with their own MAC. Your computer picks up one MAC that happens to arrive at first, communicating with it. After a certain timeout the same procedure is repeated so you will suddenly communicate with the other device. – user3767013 Oct 9 '14 at 8:00
  • The DHCP server in the router will not only assign your computer with an IP address, it also tell your computer to send all data to itself. So you must disable the DHCP server on the second router, letting your computer to send all data to the router holding the internet connection. – user3767013 Oct 9 '14 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.