10

I have created a separate question Google Chrome completely unresponsive on the problem that may be fixed in this way.

The browser cannot open any page, not even the settings, plugins and addons pages.

Using the incognito window has the same problem, maybe because some plugins are still used (or loaded).

I think addons are userprofile-specific, as indicated in the solution to the question How to open Google Chrome with extensions disabled / turned off? indicated as the one to which this may be a duplicate.

Therefore, I need to try to start with no plugins (and this one is no duplicate).

Is it possible to start Chrome in safe mode or something so that no addons or plugins are used?

(I mean start the browser already with all those disabled, because, as presented in the other question linked above, I cannot access settings nor plugins because NO window works, NOT EVEN Settings (chrome://settings/), About Google Chrome (chrome://chrome/) or Downloads (chrome://downloads/)!)

  • @DavidPostill - that is about addons: I am asking about plugins too – user162573 Oct 8 '14 at 8:51
  • @DavidPostill: also, that answer says to go to User Data folder (C:\Users\%USERNAME%\AppData\Local\Google\Chrome\User Data\Default) that is to the Default profile. That is related to a certain profile. My problem affects all profiles, which maybe means it's something not related to addons, but to plugins. – user162573 Oct 8 '14 at 8:57
  • "This question may already have an answer here: How to open Google Chrome with extensions disabled / turned off?. It has NOT. – user162573 Oct 8 '14 at 9:00
  • Out of curiosity, now you have accepted the answer from @DavidPostill, could you let us know if Chrome now works and which plug-in was at fault? – AFH Oct 8 '14 at 10:25
17

Source List of Chromium Command Line Switches

--disable-extensions Disable extensions.

--disable-plugins Prevent plugins from running

You might also find the following useful:

--debug-plugin-loading Dumps extra logging about plugin loading to the log file

How to add these options to a Chrome shortcut

enter image description here

  • Right click on your Chrome shortcut
  • Select Properties.
  • Add to the end of the Target field --disable-extensions --disable-plugins

It will look like:

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" /high-dpi-support=1 /force-device-scale-factor=1 --disable-extensions --disable-plugins

  • Click on OK
  • Start Chrome.
  • 1
    This didn't work for me on Chrome 68, Windows 10. – Bram Vanroy Sep 25 '18 at 7:26
  • 1
    I am looking to do this on Ubuntu if anyone knows how. – MrCholo Nov 29 '18 at 2:27
  • @MrCholo (Sorry for imprecise instructions because I have Kubuntu not Ubuntu) Right click your Chromium (or Chrome) somewhere (like Applications menu) and choose edit application or properties or open with gedit. There should be a line like chromium-browser which you would change to chromium-browser --disable-extensions --disable-plugins. – Carolus Apr 1 at 8:52
2

Create a .bat file

taskkill /F /IM chrome.exe 
taskkill /F /IM iexplore.exe
taskkill /F /IM googleupdate.exe
taskkill /F /IM outwit-hub.exe

start chrome --disable-extensions
0

You could use the command line option --disable-plugins to disable plug-ins.

Other possible solutions to the apparent problem are rebooting your system, clearing your browser cache, running an anti virus system check, attempting an update, attempting an installation repair (if Chrome has that feature), and doing a full uninstall and reinstall.

  • already did reinstall, no use – user162573 Oct 8 '14 at 9:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy