0

I have a fresh installation of Manjaro linux 0.8.10 with vim 7.4 installed, and I'm unsuccessfully trying to enable syntax highlighting for c++11/14 using the script by Michael Small (which I've been working with until recently), or vim-cpp-enhanced-highlight which I've never tried before.

I've googled around, and followed any clue I could found. The best I got, is making highlighting work for some small subset of the keywords (e.g: "return", "using", "size_t" and "std", but not "static", "class", "public" or "const"), and it doesn't seem to recognize any of my own types, function calls and so on.

I've tried the following things:

  1. Using the original cpp.vim from /usr/share/vim/vim74/syntax, and placing cpp.vim from vim-cpp-enhanced-highlight in ~/.vim/after/syntax
  2. Placing cpp.vim from vim-cpp-enhanced-highlight in ~/.vim/syntax
  3. Override cpp.vim in /usr/share/vim/vim74/syntax with the file from vim-cpp-enhanced-highlight.

and pretty much the same variations with the .vim files taken form Michael Small (and I'm reasonably sure I didn't make any mess, and I restored the original configuration before each trial).

I'm using the same .vimrc file that I've used before (and which worked with Michael Small's files). It has in it "filetype plugin on" and "syntax enable". I've also tried placing there "au BufNewFile,BufRead *.cpp set syntax=cpp11" (which had no measurable impact), and I've tried setting the syntax configuration manually from inside vim (e.g. "set syntax=cpp" or "set syntax=cpp11") which had rather strange effect (toggling the highlighting for only the "std" keyword).

I guess it's obvious that I don't know what I'm doing. Could it be that I should be using a different build for vim, compiled with some support for c++? If so - is there such a package for manjaro?

I'd appreciate any help.

Thanks!

0

I don't know what the problem was, but it's gone now: I removed vim (pacman -R vim), manually deleted the directories /usr/share/vim/ and ~/.vim/ and reinstalled vim and vim-runtime. I then placed my colour scheme in ~/.vim/colors and my syntax files in ~/.vim/after/syntax - and it's working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.