8

Up until now when I clicked Save as in FireFox it used to save the content from DOM. However now that FireFox updated to version 32.0.3 it saves the original html instead and all changes that were made to the page after it was loaded are lost (ie. content from ajax calls).

How do I get the old Save as functionality back (yes, I need it the way it was)?


Update: I tested Save as on another machine running FireFox 32.0.3 and had the expected result. I need to conduct further test, to determine how those two are different.

  • Install a previous version of Firefox? – Dave Oct 9 '14 at 7:42
  • 3
    @Dave but then I will be stuck with an old version of Firefox and miss other updates and face security risks etc. – jahu Oct 9 '14 at 8:08
  • Well, I mean, have both installed. Although it won't fix your concern about the security risks – Dave Oct 9 '14 at 8:13
  • well, you could just copy the html after the changes, with the developer console. F12 -> Elements -> Right click html tag -> Copy as HTML option – w0rldart Oct 9 '14 at 8:19
3

I found out what was wrong. The saved as type was switched to *.* in the save file dialog (for the save as file option obviously). With this setting on, Firefox was saving the original html. With any of the other settings (including txt) Firefox was saving content from DOM (with all the changes). For a second I was wondering if this is perhaps an undocumented feature, but here it says:

All files: This is equivalent to "Web page, HTML only," but you may specify a file extension (e.g. ".htm" or ".shtml").

Which would makes me believe it's a bug. I mean, it's a bug because the behaviour differs from the "Web page, HTML only" option.


Update: I tested that yesterday and I was quite sure that Web page, HTML only saved a modified version of the html, yet when I repeated the test on another machine I got the original html file. So the "bug" part might actually be my mistake. Nonetheless, if your firefox saves you the original file instead of the modified content, then make sure that saved as type is not set to Web page, HTML only or All files.

  • I made the same mistake, thinking that "HTML only" included all the DOM content... If I hadn't seen your answer, I would have wasted a lot of time. Thanks! =) – user21820 Apr 4 '17 at 4:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.