0

I have installed zsh and git on SLES 11 SP2. When I try to trigger an auto complete for a git command I get the following error message:

zsh git completion reports _git:4113:

This is my .zshrc

# Lines configured by zsh-newuser-install
HISTFILE=~/.histfile
HISTSIZE=1000
SAVEHIST=1000
setopt appendhistory autocd extendedglob nomatch notify
unsetopt beep
bindkey -v
# End of lines configured by zsh-newuser-install
# The following lines were added by compinstall
zstyle :compinstall filename '/home/d045803/.zshrc'

autoload -Uz compinit
compinit

autoload -U colors && colors
PROMPT="%{$fg[red]%}%n%{$reset_color%}@%{$fg[blue]%}%m %{$fg_no_bold[yellow]%}%1~ %{$reset_color%}%# "
RPROMPT="[%{$fg_no_bold[yellow]%}%?%{$reset_color%}]"
source ~/.zshgitstatus

source ~/.aliases
source ~/.environment
source /etc/profile.d/proxy.sh

I have nearly the same setup on my Archlinux box. The git completion works fine there. Do you have any ideas what might be going wrong here?

Robin

0

I was able to solve this one on my own. ;-) It seems that the zsh version from the SLES repositories was too old to be used in conjunction with a rather fresh git (which we get from an additional repository). I built zsh from source and tried git completion. Now it works without any issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.