1

Basically the question says it all. I have an Asus N55SF laptop with a fresh install of Windows 7 ultimate (with all the updates) and no Asus pre-installed software (eg: Asus Power management tools... all drivers and chipset updates are installed) nor other power management tools installed, nor other software that can potentially override the settings. Also, have an external monitor plugged via the lateral HDMI port.

Power settings, for both battery and plugged-in, are set so that the laptop will never power off disks/monitor, sleep nor hibernate. That is both for idle time and laptop lid's closing.

I'd like to use the external monitor only, with the laptop always closed but apparently it's not possible. Whenever I close the lid, I get maybe up to 15-20 minutes worth of usage then it hibernates (or sleeps). If I then try to re-awake it, that doesn't work, and I have to press the power button until the laptop reboots.

What is going on? What should I change/check to have this setup working as I want it to?

4
  • Since the you did a fresh install, and no Asus pre-installed, I assume that you didn't get install the drivers probably, I suggest you go back to Asus drivers page and see what you missed, the download and install the drivers (beginning with Chipset if you didn't install it on the first place).
    – iSR5
    Oct 10, 2014 at 11:57
  • hum no I have all the drivers, I shall update my opening post :) Oct 10, 2014 at 13:18
  • Before I answer, if I find a laptop at home I'll check it out. Though basically, go to your power options, click properties, and power off disks will be an option and for how long.
    – Brok3n
    Oct 10, 2014 at 15:18
  • 1
    That's set to Never already Oct 10, 2014 at 15:26

8 Answers 8

10

Laptop ignores power settings, closing lid always sleeps/hibernates, why?

powercfg might give you some hints.

Open a command window and run:

powercfg -getactivescheme

The GUID of the active scheme will be returned:

Power Scheme GUID: a1841308-3541-4fab-bc81-f71556f20b4a  (Power saver)

Now query the default scheme:

powercfg -q a1841308-3541-4fab-bc81-f71556f20b4a

This will return the contents of the active scheme. Look for the section containing Power buttons and lid:

  Subgroup GUID: 4f971e89-eebd-4455-a8de-9e59040e7347  (Power buttons and lid)
    Power Setting GUID: 5ca83367-6e45-459f-a27b-476b1d01c936  (Lid close action)
      Possible Setting Index: 000
      Possible Setting Friendly Name: Do nothing
      Possible Setting Index: 001
      Possible Setting Friendly Name: Sleep
      Possible Setting Index: 002
      Possible Setting Friendly Name: Hibernate
      Possible Setting Index: 003
      Possible Setting Friendly Name: Shut down
    Current AC Power Setting Index: 0x00000000
    Current DC Power Setting Index: 0x00000000

The above is part of my default scheme. You can see that the value for this entry is 0x00000000 which corresponds to index: 000 (do nothing).

Check your value is set to what you think it should be (and check the remaining entries as well)


How do I change my power settings?

powercfg can be used to change some settings from the command line:

  • Switch power scheme
  • Change timeout values for disk, display, sleep and hibernate.

To change other values:

  • "Start" > "Run" > "Control Panel" > "Hardware and Sound" > "Power Options" > "Change Plan Settings" > "Change Advanced Power Settings" as mentioned in the answer by Tyler B. Long.

Further Reading

4
  • 5
    This is a great tool, but it doesn't answer how to change settings to resolve the OP's issue.
    – CharlieRB
    Oct 9, 2014 at 15:09
  • 1
    Tried it, just for the sake of trying it. All corresponds to "Do nothing" but laptop still does some things :( Oct 9, 2014 at 15:17
  • This answer helped me solve the issue. Using this I figured out that the Control Panel GUI was showing "Do nothing" but powercfg was showing 0x00000002. So I set the value to something else in the GUI, saved the changes and set it back to "Do Nothing". Then it worked. powercfg output was also reflecting 0x00000000 correctly.
    – Raghav
    Aug 28, 2019 at 1:30
  • What should I do if "Lid close action" doesn't appear in powercfg -q? How do I get the lid close action to save? Changing it then changing it back did nothing. Jun 11, 2021 at 20:58
1

I had the same problem with my ASUS laptop. Even though I had "Do Nothing" in the "When I close the lid" setting, but the laptop would still go to sleep when I closed the lid. All I did to correct this was that I just changed that setting to something else and then changed it back to "Do Nothing" and then started working like it was supposed to.

1
  • this didn't work for my asus laptop May 20 at 12:50
0

Updating Smart Gesture

It seems like for some people, updating their smart smart gesture fixed it for them. As seen in the thread here

I too had the same issue with my S46-CM. There was a lot of talk in another thread about Smart Gesture being the culprit for sleep profile and processor maximum states being reset. I notice in the software section they just recently updated Smart Gesture for my computer. After installing the update, the issue has been resolved. Maybe try the same for yours if there is an update?

To update your drivers, go to the N55SF Driver & Tools in the Asus website, select your OS and find the drivers for Smart Gesture.


Uninstalling Instant On

This was the fix that helped me remove the problem for my Asus K55VD. When I changed the default plan for "Power saving mode" and restarted, a notification came up saying:

Don't change your plan settings, it has been reverted back.

After that, I knew it was the Instant On from Asus since it was the icon for that notification. I quickly uninstalled the program, and the settings were already back, and restarted also didn't revert it back.

0

This may sound stupid but the way I got it to work, is by creating a new scheme(I picked the one for maximum performance, if that matters, didn't test that), and used that instead. enter image description hereenter image description here

0

This is the only thing that worked for me.

  1. open command prompt

  2. Type the below

    powercfg -restoredefaultschemes

  3. hit enter

This undid all my previous unsuccessful configurations. I was back on 'balanced plan' and this time when I changed what 'closing the lid' and 'when computer sleeps' it worked.

-1

Go to the following path:

Control Panel > Hardware and Sound > Power Options > Change Plan Settings > Change Advanced Power Settings

The advanced power options menu will display. This is basically the GUI version of the powercfg tool mentioned in this post. Look for the "Power buttons and lid" menu and expand its sub trees. Be sure to verify all other settings in this dialog window for things not matching your criteria.

1
  • doesn't really resolve the issue, they've already stated that they've set those settings, but that they seem to be being ignored.
    – GeorgeWL
    Dec 5, 2018 at 9:30
-1

Laptops are prone to overheat with the lid closed, and computers force a shutdown at the hardware level when overheating. Run HWINFO64 to log your temperature readings during a shutdown. https://www.hwinfo.com/download.php

-3

power usage icon in task bar. configure. button to poweroff, lid power off, system resume/never sleep most graphics. card are not compatible. most laptop cant hibernate. or save to ram/fast resume (ramboot) few times mine done it i lost my os win7 ultimate 64 some oems have ms kb***no. patch or system manual regarding. bugs fixed or patched usually in windir first folder is advanced installation. or added something. or another folder go to graphics see if if advanced info/about device properties.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.