0

I wanted to change the default DNS so as to use OpenDNS ones. I went to the router (192.168.0.1) and then put the DNS adress of OpenDNS in the WAN connection settings. It works and my computer appears to use them every time it has to search for a domain but when I come back from a long deep sleep (let's say a night for example) then my computer send request to Shaw DNS ( 64.59.144.92, 64.59.150.138) ! The problem here is I do not want any DNS queries sent out to others than OpenDNS therefore all those queries are blocked by my firewall.

I first opened a question here but then realized than the problem wasn't only openvpn but all the system sending queries to shaw which leads to that (as an example) :

rule 20.icefloor.custom.9/0(match): block out on en0: (tos 0x0, ttl 255, id 20775, offset 0, flags [none], proto UDP (17), length 59) 192.168.X.X.XXXX > 64.59.144.92.53: 32591+ A? superuser.com. (31)

I really don't understand because :

  1. OpenDNS are put in network settings
  2. OpenDNS are put in the router config

I use OS X 10.9, IP from DHCP.

  • Did you try System Prefs > Network > Advanced... > DNS – Tetsujin Oct 9 '14 at 19:46
  • Yes. That's what I was meaning by "OpenDNS are put in network settings" – Lich4r Oct 9 '14 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.