1

I have an Asus n56VB laptop that I just recently bought a few months ago. Occassionally I have noticed that the laptop wont turn on. Mostly after hibernating the laptop the night before. I have tried the trick to holding down the power button for 30 seconds (sometimes even a minute more) and it doesnt work. The last time this happened I left the laptop alone for a day with all the power source removed and it turned on. It isnt doing the same anymore. I suspect it is residual charge preventing it from starting the laptop. Is there another way I can drain out the residual charge or is there another cause to this problem?

The power light(bulb symbol) lights up and I can hear a small hum coming from the laptop when I press the power button with the battery or charger. Other than that, nothing happens even the screen is black. The laptop was fine yesterday.

Please help if you know anything about this. It is really starting to worry me.

  • You know, I thought about buying this laptop a couple of months ago from Amazon, the only thing that prevented me from buying it was the reviews that I've read claims about this problem, and If I were you, I'll contact Asus to sort things out with them since the laptop a few months old (still new). It's not fair to have problems with a few months of use. – iSR5 Oct 10 '14 at 10:56
  • I am keeping that as my last resort because usually Asus services takes very long even if the problem is simple. I was wondering if I could fix the problem by my own before I have to give it to them. I am a student who is doing FYP this year and it is going to be problematic for me if I dont have my laptop during this time. Thanks though :-) – Rowx Oct 10 '14 at 11:10
  • Oh, that's a really bad timing then :(, If you did try to drain the residual charge and didn't work, then try to use another AC charger, and do the same method, just make sure there's nothing connected while doing the drain method. – iSR5 Oct 10 '14 at 11:22
  • What research have you done? Are the BIOS up to date? If this is under warranty, contacting the manufacturer should be the first thing you do. Messing with things on your own, or by suggestion of others, could possibly void your warranty in some cases. – CharlieRB Oct 10 '14 at 11:31
  • Still not working. Tried a few times. No battery or ac plugged in while draining :( – Rowx Oct 10 '14 at 11:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.