10

I'm on Windows 7. I just ran a Power Efficiency Diagnostics Report through powercfg -energy and I got this error:

Platform Power Management Capabilities:PCI Express Active-State Power Management (ASPM) Disabled
PCI Express Active-State Power Management (ASPM) has been disabled due to a known incompatibility with the hardware in this computer.

I did some research in the Microsoft forums and it seems like a lot of people have this issue, but MS hasn't given anyone any satisfactory answers:

If there's anyone at Microsoft who actually knows what the "known incompatibility" is, they aren't saying. After searching Microsoft's website and the web for an answer and finding none, I've come to the conclusion that this is another one of those incomprehensible Windows messages that Microsoft tries to ignore ("...consult your original equipment manufacturer for assistance...") and nobody else can figure out.
from: http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/pcie-aspm-is-disabled-due-to-a-known/6ca12628-42ca-4804-af75-948199a7538a
more: http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/platform-power-management-capabilitiespci-express/8611ba23-8091-46ac-b1f3-97cba5b43455

Have any SuperUsers encountered this "hardware incompatibility" and figured out a way around it?

2

Try unplugging all accessories from your computer (keyboard, mouse, external hard drives, etc...). The error message means that a device that is attached your computer is causing ASPM to be disabled.

My PC stopped going to standby for some reason, and I tracked it down to this error message. I was able to fix the issue by unplugging one of my USB devices (a Playstation controller to PC USB adapter).

Some useful resources for investigating this issue:

  • MCE Standby Tool (archived link) - Provides a lot of useful information. For example: the "Windows Idle" tab told me that the "time since last user input" was pegged to 0 (either because ASPM was disabled or the USB device kept sending rogue input.) This counts up when the rogue USB device is disconnected. Hasn't been updated in a while, but the beta version seems to be mostly functional in Windows 10.
  • Basic Diagnostics for Hibernate and Sleep. Good list of things to check and explanation of background details like sleep states. Led me to try powercfg -energy
| improve this answer | |
0

Resolved: The error existed for about 3 weeks. Tried everything that this and other websites recommended but nothing worked. Here is what happened (I'm not claiming this is a solution), but, I my laptop goes to sleep now. It just happened that I opened my "google drive" and "Google photos" (the app & the website), I also opened my "pcloud" website. Suddenly the computer went to sleep, I ran the Powercfg /Energy and the error is still there but, the computer sleeps every time I tell it to or on its own after the set times, with no problems.

| improve this answer | |
0

Answers here are meaningless.. to even actually backwards.

ASPM is a PCI Express thing, it has nothing to do with other kinds of devices, and it was mandatory to support already by the first release in 2003 (even though this requirement was later relaxed in 3.0.. but I would think just about all consumer hardware sticks to the original behavior).

Support in theory though, doesn't mean you (the firmware, or the OS) are forced to enable it. And this is what we are talking about here eventually.

One of the many caveats, is that there is a plethora of (desktop?) motherboards that for a reason or another set the ACPI 4.0 "PCIe ASPM Controls" FADT field to 1. Meaning the OS power management should avoid "any touching" (maybe they aren't trusting it to setup everything properly, or perhaps they just don't feel like whatever the power saving could be worth any possible slowdown).

Anyhow, you can just hope your BIOS offers the right knobs to enable it, otherwise your only chance is to toggle yourself the PCI configuration space registers.

| improve this answer | |
-1

This might sound faceious, but the way around it is new hardware. If it's a known hardware incompatibility no amount of tweaking is going to fix it. Your only saving grace might be a future firmware or BIOS update, but I wouldn't bet on it.

| improve this answer | |
  • Makes sense, but how do I know if the new hardware I get is going to be compatible or not? Since the diagnostic describes it as a "known incompatibility", hopefully someone can explain what exactly is causing the incompatibility, so I know what part to replace, or what firmware to update. – Egghead99 Oct 10 '14 at 15:57
  • You can search for motherboards that have a compatible northbridge chipset. – Mr. Mascaro Oct 10 '14 at 16:00
  • I guess I'm still not understanding the underlying issue. So you're saying that the incompatibility is my motherboard? And that in order to enable PCIe ASPM I need a new motherboard that supports it? What are some examples or rules of thumb for motherboards that do support it? – Egghead99 Oct 10 '14 at 17:56
  • 1
    Not always. I have a 3 week old Dell laptop that exhibits this issue... (an xps13) – Jonesome Reinstate Monica Mar 14 '16 at 20:41
  • 2
    This answer badly needs elaboration -- it doesn't explain much. For example, that old hardware may benefit from new firmware or drivers which may help alleviate the problem or fix it altogether. This answer might have been an okay addition to a user forum but it's hardly worth much on Super User. You don't tell super users to go and buy new computer. At least because there's plenty of people running expensive state of art workstations that get the same warning. ASPI has been around for years, too. – amn Aug 27 '19 at 9:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.