2

As you can probably tell by the title, I'm a complete novice in Linux environments.

Trying to work out how to install apps using sudo apt-get install. I have been able to install some, but recently it started to fail.

For example I'd like to install elementary-tweaks, but the error message is the same, for all E: Unable to locate package elementary-tweaks

I THINK I understand that if I add a PPA I should access the packages associated with that PPA.

Therefore I have tried removing previous PPAs (as seen on some answers on this site), and add this: https://code.launchpad.net/~versable/+archive/ubuntu/elementary-update followed by a sudo apt-get update.

I have also tried sudo apt-get -f install, PPA purge, etc...

Still, the error message remains.

Error message:

Reading package lists... Done
Building dependency tree        
Reading state information... Done
E: Unable to locate package elementary-tweaks

Could anyone please point it out for me, what am I missing in this? Also that what is a possible resolution to similar cases?

Thanks!

  • It'd be useful if you provided the exact error message text, what command you're running, etc. The devil is likely in the details. Does the package show in a apt-cache search? – ernie Oct 10 '14 at 22:04
1

That's should work for any Elementary OS, the proper way to add ppa

sudo apt-add-repository ppa:versable/elementary-update
sudo apt-get update
sudo apt-get install elementary-tweaks

So .. If that not work then update the Q with the Error

  • 1
    went through your instructions -- in the end, still says "unable to locate package elementary-tweaks" – alernerdev Oct 9 '18 at 19:04
  • that will work only for 0.3 Freya which are based on ubuntu 14.04. elementary-tweaks not updated to work with 0.4 Loki launchpad.net/elementary-tweaks/+packages – Ahed Eid Oct 10 '18 at 9:47
0

make sure you're in the home directory. just close out the terminal and open a new terminal window.

via https://launchpad.net/elementary-tweaks:

sudo add-apt-repository ppa:mpstark/elementary-tweaks-daily && sudo apt-get update && sudo apt-get install elementary-tweaks

  • are these instructions no longer valid? I am getting a lot of "Failed to fetch" messages, and there is no tweak package in the end. – alernerdev Oct 9 '18 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.