6

I've tried both of the suggestions mentioned in this thread, but neither of them worked.

I have 4 file shares hosted on a file server running on my local network. These shares are set to automatically mount on login. When I login however, I get the "Could not reconnect all network drives" system bubble that looks like this:

Could not reconnect all network drives

However, if I go into Computer, select all of the drives and press enter, they open and work without any problems.

The client is running Windows 8.1 and the Server is running Windows Server 2012 R2. Both are running in a workgroup environment.

1
  • The link you posted wasn't relevant - the issue is not that it never connects, just that it doesn't connect immediately. I'd just ignore the warning, if it always does connect by the time you need it - my remote iTunes library does the same sometimes, but gets there eventually after another 30s or so. – Tetsujin Oct 11 '14 at 18:00
4

I was able to solve this problem by marking my file server as a trusted local intranet site in Internet Options. Whenever I would copy a file from my share to my computer I would get security warning, and Office would open all documents in read-only mode as if I downloaded them from the internet.

I fixed it by doing this:

  1. Open Control Panel, select Network and Internet
  2. Click Internet Options and go to the Security Tab
  3. Select Local intranet
  4. Click the Sites button and then click Advance
  5. Add file://<IP address or NetBIOS name of your file server> with no trailing slash.
  6. Make sure that "Require server verification (https:) for all sites in this zone" is not checked

Example of Local Intranet Sites

1

This is a fairly common problem. As this site states:

Whatever the reason, it is commonly reported that mapped network drives appear as ‘disconnected’ in Windows Explorer (or ‘unavailable’ via net use), and that programs that attempt to use these drive mappings will fail until the user physically clicks on the drive letter in Windows Explorer. Only this user-initiated action will restore the connection and allow other programs to successfully read from the drive letter.

So the author of that site wrote a handy utility to solve this problem: MapDrive. If your browse the page, there is a really detailed explanation how to use this program in both elevated and non-elevated states.

This utility solved the above-mentioned problem for me.

2
  • 4
    I'm really not that eager on using a third party tool to mount my shares when I know Windows can do this on its own. – ecnepsnai Oct 11 '14 at 18:15
  • @ecnepsnai fair enough, but i just stopped looking any further when i found this solution. – RusI Oct 11 '14 at 18:18
0

I'd suggest it is the workgroup environment as odd as it sounds. Domain networks would join instantly, and I'd never map drives over a workgroup because of the DNS resolutions and the credential differences.

Are you using a hostname to map the drives?

3
  • No, I am using the IP address of the server. – ecnepsnai Oct 11 '14 at 19:57
  • Hmm... credentials are stored on both sides? – EdG Oct 11 '14 at 19:58
  • I already had the credentials stored on the client, added them to the server but it didn't fix it. – ecnepsnai Oct 11 '14 at 20:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.