17

I recently updated my video card drivers to the latest version (AMD Radeon HD 6700 series) and found that upon doing so, all the "GIF"s on Imgur (which have now switched to "GIFV" which is an MP4 played in the browser to speed up loading times and allow larger uploads) are showing black and / or glitches frames for a varying amount of time.

Screengrab

On the left is the video about 2 seconds in. On the right is when the video has looped. This happens with every GIFV I view on Imgur, a random assortment of YouTube videos but so far, no videos played on my Windows 8 "Modern" apps or on VLC. I also see this issue on several client computers, but can't work out what's going on.

The 'video' will eventually come good after it reaches the end and loops back (e.g. on imgur) or if the scene changes in a significant way (e.g. the camera angle changes, the lighting in the scene goes from really dark to really light or the camera zooms or pans in more than a subtle manner)

For reference, I'm using an AMD Radeon HD 6700 series card (I think it's the 6770, Device Manager isn't helpful, nor is looking up the device ID on the internet). I'm running Windows 8.1, fully updated. This happens in Google Chrome 39.0.2171.13 beta-m and Firefox 32.0.3, it works fine in IE, but then again I get big video controls over the top of the GIFV on Imgur, so I don't know if that's causing the scene to 'refresh' and avoid the black glitches.

What is causing this, why does it only come good after the scene being shot changes and how can I fix it?

10

This happens in Google Chrome 39.0.2171.13 beta-m and Firefox 32.0.3, it works fine in IE.

To me, this is the key. I wonder if this has to do with 3D acceleration mucking up video playback. Meaning, modern browsers such as Chrome, Safari and FireFox have hardware acceleration of page content set as a default.

The way it works is—for all intents and purposes—the browser window is treated as one, flat side of a 3D object. The browser pushes all of it’s rendered content through the video card driver and it displays on the screen. If all goes well, the content looks exactly the same as what happens when the image is rendered directly through the system, but it should render a bit faster on more complex pages.

I would poke through the Chrome and Firefox settings to see if you can disable video acceleration. Perhaps even in the driver itself? Now that would at least get the video to display properly in your browser, but the deeper issue of why they are not playing nice is still in play. That I’m not clear on, but it could simply be a driver issue or even a driver preferences issue. Maybe dig into the system and see if you can trash the driver settings to force it to create a new file?

| improve this answer | |
7

To answer why you see glitched black frame,

Video files are not just consecutive images (like for example GIF format), they have various ways of compression. Here is a cool video explaining the compression taking place here (the explanation is ~first 3 minutes of the video). For some reason the browser doesn't load the first image in the video clip properly, instead just shows a black screen, so you get that black glitch. If you immediately skip to the begging or just wait until the entire scene has changed, the bug will disappear because the player was forced to load an entire image.

| improve this answer | |
  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Dec 15 '15 at 13:41
5

Hey everybody i had the same problem. what fixed for me is go to new tab type chrome://flags and search GPU rasterization MSAA sample count i had it on 0,set it to 16 and the problems are magically fixed. (i have GTX980Ti) let me know if it worked. turning off Hardware accerlation completely works aswell but some demanding things start to lag if you dont have very powerful cpu (ex:6K60fps video)

| improve this answer | |
  • Did not work for me, had to turn off accelerations completely. – Noishe Jul 25 '16 at 0:55
3

I had the same problem. I don't know if you found the solution yet but I found it on this website:

I am pasting the comment here: I found a solution. I had already tried installing the codec pack, but there was no difference. I went into chromes setting here: chrome://flags/#disable-accelerated-video-decode, and disabled it, enabling acceleration. Now everything looks great. And videos seem to be running clear. This option is different from the one I found in chromes settings disabling 3d acceleration.

For me enabling it worked! Weird!

| improve this answer | |
1

A fix I found for Chrome was going to your flags (chrome://flags in a new tab) and disabling Hardware-accelerated video decode.

| improve this answer | |
0

My laptop was doing the same. I went into Google Chrome settings, then advanced settings, down to system and unticked the advanced acceleration box. I then restarted chrome and now it's all good.

| improve this answer | |
  • 1
    This seems similar to another couple of answers here which mention acceleration; is this a different setting? – bertieb Mar 1 '17 at 20:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.