2

I have just turned on internet sharing on my iMac so my phone can connect to the internet via my iMac (there is only one ethernet connection in this hotel, and no 3/4G). When I try opening Google, everything works fine. However, when I open Clash of Clans, it just gets stuck at the loading screen, and nothing happens.

Why is it that just Clash of Clans isn't loading? Other games work perfectly fine, at normal speed.

| |
  • 2
    A bit of googling reveals Clash of Clans is an Android game, presumably on your phone. It would seem likely your Internet sharing (bridging) isn't conveying a socket connection the game sees as essential. See TCP/UDP socket 9339. – user187561 Oct 13 '14 at 5:15
  • See Mac Internet Sharing Port Forwarding??. Note 9339 isn't one of the passed ports in the example at the Mac OS X: Set Port Forwarding Nat Router (Internet Sharing) link (section entitled How Do I Setup Port Forwarding OS X Router?). – user187561 Oct 13 '14 at 5:33
  • Sounds like an answer, @David! It might also be the hotel network that is blocking things. – Arjan Oct 13 '14 at 5:41
2

A bit of googling reveals Clash of Clans is an Android game, presumably on your phone. It would seem likely your Internet sharing (bridging) isn't conveying a socket connection the game sees as essential. See TCP/UDP socket 9339.

Note 9339 isn't one of the passed ports in the example at the Mac OS X: Set Port Forwarding Nat Router (Internet Sharing) link (section entitled How Do I Setup Port Forwarding OS X Router?)

| |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.