I'm trying to make a USB stick installation disk for Windows XP. I've done this several times before (using this method), but now it's failing, and I don't know why.

The only thing that's going wrong now is formatting the USB stick, which is PeToUSB's job.

One of my USB sticks is recognized, but it's bigger than 4GB, and PeToUSB fails to format it with FAT 16.

The other is smaller than 4GB, but it's not being recognized as a USB stick by PeToUSB, nor by Windows (I tried on XP and 7), both see it as a fixed hard drive.

I already tried to zero-fill, re-partition and re-format it, but the problem always keep happening.

Then I tried formatted it using fdisk + mkfs.vfat on Linux, and with Gparted, always using FAT16 and setting LBA flag on, as PeToUSB would do, and then skipping to the next steps.

But it never works, it just doesn't boot. Formatting with fdisk + mkfs.vfat it doesn't do anything (Even though it have the 0xAA55h code on the last bytes of the boot sector), and when formatted with Gparted, it gives me a message that the disk is not bootable (this message is displayed by the code on the USB stick, and not by the BIOS).

So, my questions is:

Does anyone know how can I format it as PeToUSB does, or know how can I format it properly?


1 Answer 1


Hey there you must format any drive > 2GB with FAT32 otherwise it wont work !!

If you format a drive bigger than 2GB the clustersize will be >32kb.

This toggles your filesystem unbootable!

see: http://en.wikipedia.org/wiki/File_Allocation_Table

  • But i've always used 4GB usb sticks. The guy on the example also uses a 4GB. Maybe PeToUSB is formatting it to FAT32? Oct 14, 2014 at 16:09
  • there is a better tool... ill send the name when im at my homecomputer ..
    – Emjay
    Oct 14, 2014 at 16:20
  • I tried formatting it with FAT32 and the same problem keeps happening, it doesn't boot. Changing the bootable flag of the partition some times makes a message appear, like "Disk Error", but it shouldn't be necessary, as the disk MBR (and not the partition "MBR") is being used to load NTLDR. I also tried making a 256MB FAT 16 partition with a 8K cluster, but it is still unbootable. Oct 14, 2014 at 20:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .