25

My MacBook Air keeps dropping wifi connection on my home network. When I connect to my network, it remains connected for a few minutes, then it drops the connection. I have no idea what's the problem. I found several forums on the internet discussing this, but none of them really gave a working solution. My MacBook is 13" 2012 base model (MacBookAir5,2), I'm running the latest developer version of OS X Yosemite as of October 14th 2014 (GM 3.0 I believe), and my router is a TP-Link TL-WR741ND. These are the things that I found on the internet, and I tried all of them:

  • Upgrading the router to latest firmware, resetting it
  • Changing the WPA2-PSK mode to AES
  • Set a different channel on the router
  • Deleting the network information as well as related keychain items, repair permissions in Disk Utility, restart, reenter password for network
  • Simply turning off/on the wifi on my computer
  • I set the permissions of the Keychain items for my network so that every app can access it
  • Swap the router for a different one (exact same kind, I have two of them)

All this with no luck. My MacBook still drops wifi every couple of minutes. I have been using the same router for months now, and I never had a single problem with it. This only started recently. I wonder if it's something in the latest version of Yosemite? I have been regularly updating to the latest version of it since the first developer beta came out this summer.

So what else can I do? It's very frustrating. This is the only network that my MacBook can't handle, and this is also the only device on the network that does this. Every other network is fine on my MacBook, and every other device on this network is fine as well.

  • 1
    Option-click on the Wi-Fi Menu Extra and select Wi-Fi Diagnostics. What does it tell you? Use it to enable extra logging and keep it on until the next drop. What do the logs say? – Spiff Oct 14 '14 at 23:01
  • 1
    This is strange: it doesn't seem to drop the connection anymore. The problem somehow magically disappeared now. I don't like these kinds of problems though, they can magically appear again... Anyway, I will enable logging whenever it drops again. – adam10603 Oct 15 '14 at 4:56
  • Possibly related: apple.stackexchange.com/questions/195359/… – musically_ut Jul 31 '16 at 14:41
  • See superuser.com/questions/972037/…. Setting the WiFi to 'g' instead of 'n' worked for me. – Yohan Liyanage Nov 27 '16 at 12:21
  • @YohanLiyanage I haven't come across this issue in a long time, but that could work too I guess. I don't remember if I tried that myself or not. – adam10603 Nov 27 '16 at 12:43
15

I did some more research, and came up with a temporary solution. Not the best thing to do, but it certainly worked for me. So whoever has the same problem, do this:

  • open Automator, select Application
  • add a Shell Script item
  • enter the following command in it: ping -i 0.2 192.168.1.1 (or whatever the IP of your router is)

Just save the app, start it and let it run. This will prevent your mac from dropping the connection.

The problem is that OS X tries to put the WiFi antenna into a power saving mode if there's no data being sent or received, but with some WiFi APs, this leads to disconnecting. That ping command will ping your router every 0.2 seconds, preventing OS X from turning off the WiFi.

This is not a brilliant solution, but it will work until Apple does something about this.

  • 1
    Almost 9 months later and this saved me on a macbook air from early 2015, on Yosemite 10.10.3. Do you know is this workaround consumes noticeable more battery, or any other trade-offs? Thanks! – jotadepicas Jul 12 '15 at 14:46
  • 1
    @jotadepicas It's certainly not a good idea to constantly ping your router for no reason, but I don't think it impacts battery life or anything significantly. To be sure, check Activity Monitor to see details on CPU usage and other stuff. – adam10603 Jul 14 '15 at 7:19
  • 1
    Any answer from TP-Link? I believe it might be related with them. I have a SuperHub router and it works perfectly, then I extend the connection to the living room by using a TP-LINK adaptor (TP-Link TL-WPA281KIT AV200 With 1 LAN port 300M Wireless ) and THERE in the living room is where I'm having the problems. – Alvaro Sep 12 '15 at 12:08
  • This is annoying that we have to do this....It works great...but apple should do something about it! – James111 Apr 14 '16 at 1:36
  • how can i get rid of that? Whenever i connect my macbook air my other device's internet not works. – Devendra Singh May 10 '16 at 6:51
4

The WiFi on my iMac kept disconnecting each time the computer went to sleep, about 15 min when computer was not used. I solved it by going to energy saver in system preferences to extend the computer sleep time and unselected the "put the hard disk/s to sleep when possible" The display sleep time doesn't matter, it's the hard drives that should stay awake much longer. It worked for me.

  • this works for me. – fanchyna Feb 17 '16 at 15:52
3

Apple support cleared this up for me. I needed to clear out all wifi networks saved under the preferred networks tab Networks>Advanced>Preferred Wifi Networks - with the exception of the network created to login to our secure office environment. Turns out I had a bunch based on travel, and there may have been one or two my machine favored for some reason. Anyway - this seems to have done the trick. No drops over the past few hours.

  • Even a clean install did not help in my case. – Lenar Hoyt Aug 25 '17 at 9:28
1

The Yosemite update 10.10.2 (published 27.1.2015) fixed this problem on my MacBook Air (13-inch, Mid 2013).

  • Not in my case, MacBook Air 13" Mid 2011 on Sierra 10.12.6. – Lenar Hoyt Aug 25 '17 at 9:29
0

I have a Netgear dual band router and both bands had the same SSID name. So I made them different names and so far it's solved.

I've read varying opinions on whether the SSID names can match when using a dual band router. I figure making them different names is the safest way to go for now.

0

I went to the BT site and swap the speed for this device from dual speed to just 5 GHz. Apparently some devices don't like dual speeds. Anyway this solution worked for me. The text is as follows:

How do I change the wireless channel on my BT Home Hub 5?

We suggest you carry out a wireless channel refresh rather than choose a wireless channel manually. This will ensure the BT Home Hub 5 chooses the best channel available and Smart Wireless will continue to automatically monitor the channels to maintain a good connection .
If you decide to continue with manual selection the Smart Wireless feature will be turned off.

How to change your wireless channel manually?

  • Open the web browser on a computer or device connected to your Hub and go to http://bthomehub.home to open the Hub Manager
  • Click on Settings.
  • Enter the admin password. Unless you've previously changed it, you'll find the default password on your Hub settings card on the back of your Hub. If you have changed it and now forgotten it, you can use the password override feature to set up a new password
  • Click on the "Advanced Settings" tab, then click Continue to Advanced Settings
  • Click on the "Wireless" tab To manually select the wireless channel for the "2.4 GHz" band: Go to the 2.4GHz page and select a channel from the drop down menu next to "Wireless Channel". First try channels 1, 6 or 11
  • Click Apply to confirm the change. Then wait 60 seconds for your computer to automatically discover the new settings. There's no need to change any settings on your computer
  • You can do the same on the 5GHz page to change your 5GHz wireless channel. We recommend selecting channel 36, 40, 44 or 48
0

Did the same as all the other forums suggested with no result either. Then did the following, which although not ideal finally works so I can stay on the home network more than 15-20 seconds.

  1. Reversed the keychain action to allow the network to connect via AirPort and
  2. Connected to my network and started using non-Mac software, keeping that software up which doing other things, e.g. in Thunderbird with 3 mail accounts or in Google or Firebird.

Still find Mac software slow (iTunes takes forever to connect to store), although finally the App Store software will download an update without kicking me off.

I was at the point of only staying on the network for 15 seconds if only in Mail or Safari. But by keeping Thunderbird up this AM was able to stay on-line and connected for 2.4 hours with no disconnect at this point. Next test is only open Mail or Safari and see if I stay on - then maybe it was reversing the keychain on the network back to just AirPort that was the solution.

-1

I had a problem on my Macbook which caused me trouble for a long time, but I have solved it now. It may work for you.

My problem: I had a BTHub4 and it offered 2 networks with the same name - I didn't realise it but it was a dual speed hub and the computer is supposed to automatically select the option that is best.

I had set network system preferences set to select BTHub4-FMCW ...

After putting up with the issue for a long time, I investigated the hub and discovered that the hup offered 2 conncections with the same SSID name at different speeds : 2.4 GHz & 5GHz.

I think that after sleeping my mac would just connect to the wrong SSID ... either it didn't have a password for it, or couldn't cope with the speed. Anyway it didn't connect properly ... I think the poor thing was confused and I could only connect the the Internet again by manually selecting the other connection - which was not always obvious because they had the same SSID name.

My solution: I connected to the Hub4 by typing the IP address into my browser, logged in and went to Advanced Settings/WIRELESS.

(The password is on the back of the Hub unless you have changed it)

Visit both the 2.4 GHz & 5 GHz options, and change the Wireless SSIDs so that they are different - in my case they are now BTHub4-FMCW2 and BTHub4-FMCW (previously both set as BTHub4-FMCW) .

I let them keep the same KEY password, and then saved the change.

Once you have saved, you can select whether your mac is connected to the 2.4 GHz or 5 GHz connection in your network options - previously the connection would have been automatic ... and I think this caused confusion...( I don't know because I'm not an engineer, but this is what I thought)

You may need to enter the password for the new SSID name(s) because it will be new to your Mac.

You can see which connection your mac is connected to in the BT hub 'Home' tab.

Now my Mac always connects to the 5GHz wireless connection when it wakes up and it never fails. Brilliant!

If you are having trouble with this, you may find the above change helps. I hope it works for you.

-1

I have had the same wifi issues with my lat 2012 Macbook Air (I7, 512ssd, 8GB) and haven't really been able to use it for the last three years as a result. This is where it gets a little weird...

Since the computer was basically useless without an internet connection (and Apple refused to acknowledge that this was an "issue" ???), I partitioned and installed a trial copy of Windows 10 through bootcamp. Now understand I have full AC wireless in my home and every other system has pretty much wired connection speed from anywhere in the house. Except the non-functional Mac. When I boot OSX, I continue to have the same wifi connection issues (will connect for a couple of seconds, and then revert to "Searching....", but when I boot the Windows side, my connection is instantaneous and solid. No drops whatsoever.

So, considering it's the exact same hardware, why is it that MS can somehow supply the drivers (or whatever it is) that make the wireless system work flawlessly, but Apple cannot? I'm on my way to buy a boxed copy of 8.1 tomorrow (not that I'm a fan of 8.1, but at least the $2500 boat anchor now works like a dream (and I can now appreciate the build quality of the laptop.

Who ever would have thought that Windows would fix my Mac???

  • Installing a new OS to solve a Wifi issue is not a solution; it is sidestepping the problem. – krowe Aug 27 '15 at 0:20
  • krowe, I agree that a new OS should never be required. That being said, since Apple was unable to fix their hardware/software issue and simple gave me the corporate shoulder shrug, what would you have done? I paid an armload for my first Apple computer since the 80's and it was completely unusable. I tried every fix I could find including changing out my router, etc. Now if Apple had been able to fix their own issues, I wouldn't have had to go to this extreme.My post is simply to let others with the same problem know that there IS a solution that works. – Greg Aug 27 '15 at 22:24

protected by Community Sep 27 '15 at 12:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.