0

I provisioned the Vagrant box Laravel Homestead. It is running Ubuntu 14.04.

When I see output from Node.js, I get strange characters such as » when I would expect >> or I get €â” when expecting a - and so on.

What might cause this in the configuration of the OS or Vagrant box?

0

Apparently this happens only on Windows, which can't seem to display the characters correctly in the console.

Only solution I could find was switching to a Mac.

0

I had such a problem as well when accessing my Vagrant box via PuTTY. In my case, the solution was simply to change the character set setting to UTF-8:

Change settings → Window → Translation → Received data assumed to be in which character set → UTF-8. Be sure to apply this change to the saved PuTTY session as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.