1

This question is related to this one; call it Part 2. @allquixotic provided advice on that original question, which solved the symptoms, but the result exposed an apparent underlying problem, which is the subject of this question.

The situation: The computer’s internal hard disk contains three NTFS partitions (Windows 7 main, boot, and recovery), and several ext4 partitions (Linux Mint 17 and swap). I’m currently working off an external hard disk with Debian Wheezy. All are bootable via GRUB and everything works normally; no indications of any form of corruption. Mint came pre-configured to automatically mount the Windows partition and it does, and that works as it should.

Debian did not. I set this up manually. The Windows partition is listed in /etc/fstab: fstab

(No idea why it is in such an absurd font; couldn't copy from the editor and paste it.) I created a mount folder, /mnt/windows, and used this command to mount it:

mount -t ntfs -o nls=utf8,umask=0222 /dev/sda3 /mnt/windows

I created a shortcut to the /mnt/windows folder and that is listed in the drives list of the file manager (Dolphin). After the mount command, the contents of the Windows partition are visible in the file manager either via the shortcut or /mnt/windows. I can also do a dir command in the terminal and see the contents.

Here is the problem: When I reboot, the partition is automatically mounted. The mount command verifies that it is mounted. However, the contents are not visible. The file manager shows an empty window and the dir command in the terminal shows nothing (just displays another command prompt on the next line). If I manually unmount and remount in the terminal, the contents again become accessible. So at boot time, the system is mounting the partition “in name only”; it doesn’t seem to function as if it is mounted.

The process works perfectly in Mint, so it must be related to the configuration in Debian. Any suggestions on how to fix this?

  • When you are trying to list the contents, are you doing so as root (with sudo, for example), or as a regular user? You may have to add users to default,... in the fstab mount options. – allquixotic Oct 15 '14 at 15:22
0

It appears that I stumbled across my own answer, or at least most of it.

It was obvious that mounting was taking place and the contents of the fstab entry and the mount command were different, so that looked like a good place to start. The fstab was pre-existing, possibly created when I ran ntfs-config. I guessed that the different mount points might be the problem (the partition was being mounted, just not where everything was looking for it). I changed that in fstab and now the partition is found.

The only remaining question is about the other main difference between the two specifications. fstab lists the filesystem as ntfs-3g, which appears to be a correct description. From what I see in the definition of that filesystem, one of its characteristics deals with permissions. The mount command includes a umask parameter that is missing from the fstab entry. I understand that it defines permissions, but I don't understand how to decode it. So it isn't clear whether the defaults used by the ntfs-3g entry are the same as the umask value in the mount command, or they might be different but the ntfs-3g defaults are "good enough". I didn't want to create a possible conflict by adding the umask parameter to the fstab entry. If anyone can clarify that, it would be much appreciated.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.