I have a freshly installed Arch Linux LVM inside a LUKS container all nestled on an external USB SSD. Although I have no problem with the Arch system itself, I do have a problem with Grub.

After the initial installation, I can boot perfectly normal without issue. Even logged in and configured my desktop a bit. Shutdown the system. Reboot, no Grub!! Not even a rescue shell.

So I go back to the LiveUSB, open my LUKS container, remount, chroot, grub-install (without modifying anything), exit, umount, shutdown.

Then, I can boot perfectly normal without issue. But, as soon as I shut it down and try to restart it, Grub is not working. I can do this any number of times with the same effect. I don’t notice any changes when I am initially booted into installed system or chrooted into the system.

My fstab and grub are both configured to use UUID. But, even still if it wasn’t properly configured (I wouldn't be able to boot it initially) and I should atleast get a Grub rescue shell or Arch rescue shell. But, I don’t get anything on the second boot.

Any ideas or suggestions?

Additional info:

  • Host computer: Surface Pro 1 (secure boot disabled)
  • USB SSD: Samsung 840EVO msata (mushkin Atlas 3.0 housing)
  • LiveUSB: Generic 2GB

GPT, UEFI (has a BIOS partition but I haven’t set up GRUB BIOS at all):

  • PART 1 - DATA 8GB 0700
  • PART 2 - BIOS 2MB ef02
  • PART 3 - UEFI 250MB ef00 /boot
  • PART 4 - ARCH 110GB 8e00

I’m not sure how to mark this as solved but I did find a solution and thought I should post it. Probably not the most space efficient method but it worked.

The initial grubx64.efi was inside /boot/EFI/arch directory. I made two other directories /boot/EFI/arch/Boot and /boot/EFI/Boot and copied this to both directories.

I also made a copy and renamed it to bootx64.efi and copied it to every directory containing the grubx64.efi.

I'm not sure which one is pulling the workload but I am booting 100% now.

  • Great you found a solution! The best thing to do is to just check it off as answered. Yes, you answered your own question but in cases like this it should work fine. – JakeGould Oct 15 '14 at 17:45
  • Cool, says I can't accept my own answer until tomorrow. I guess I'll have to do it later. Thanks. – David Oct 16 '14 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.