3

I'm running Arch Linux on my Cubietruck, an ARM board with more features than a Raspberry PI. In order to do so I have moved the OS data from the internal storage to a SATA hard drive.

For some reason if I add any entry to the fstab Arch Linux won’t complete boot properly.

I have made use of autofs but would rather have it mounted at all times.

Other than creating a script to mount the partition on boot by adding it to .bashrc, would there be a better solution?

More info from attempting to diagnose the fstab problem:

[xxxxx@cubier ~]$ cat /etc/fstab
#
# /etc/fstab: static file system information
#
# <file system> <dir>   <type>  <options>       <dump>  <pass>
UUID=01CFD207845300F0 /media/DATA ntfs-3g uuid=1000,defaults 0 0
[xxxxx@cubier ~]$ sudo mount /media/DATA
[xxxxx@cubier ~]$ ls /media/DATA/temp
t1  temp  test
[xxxxx@cubier ~]$ sudo umount /media/DATA
[xxxxx@cubier ~]$ ls /media/DATA
[xxxxx@cubier ~]$ sudo mount /dev/nanda /mnt
[xxxxx@cubier ~]$ cat /mnt/uEnv.txt
console=tty0
extraargs=console=ttyS0,115200 hdmi.audio=EDID:0 disp.screen0_output_mode=EDID:1280x720p50 rootwait panic=10 rootfstype=ext4 rootflags=discard
nand_root=/dev/sda2
[xxxxx@cubier ~]$ sudo vi /etc/fstab
[xxxxx@cubier ~]$ sudo systemctl start autofs
[xxxxx@cubier ~]$

This is the pastebin of the dmesg.

  • 2
    What is your actual fstab entry? Could help us all help you debug this. – JakeGould Oct 16 '14 at 4:08
  • @JakeGould the image contains basically an empty fstab. If I add anything to it such as /dev/sda3 none swap defaults 0 0 it just won't boot. It actually stops boot process for about 2 minutes, then enters the root recovery mode I mentioned. I'll reproduce it and post more details, perhaps you could help me getting to the bottom of this :) – johnildergleidisson Oct 16 '14 at 23:53
  • @JakeGould added more info ;) – johnildergleidisson Oct 17 '14 at 1:25
4

Got a reasonable solution, DE independent. By using a systemd mount as:

[xxxxx@cubier system]$ pwd
/etc/systemd/system
[xxxxx@cubier system]$ cat media-DATA.mount
[Unit]
Description = DATA partition

[Mount]
What = /dev/sda1
Where = /media/DATA
Type = ntfs-3g
Options = uid=1000

[Install]
WantedBy = multi-user.target

Thanks for the help, guys!

0

Try Gnome disks, also name gnome-disks-utility or palimpsest in order to mount correctly your partitions.

Also remember to use the UUID recognition instead of sda, sdb, etc

  • That is an alternative indeed, but I rather look for solutions that don't rely on a Desktop Environment. – johnildergleidisson Oct 17 '14 at 1:26
  • Indeed, but if it works with Disks, you can fetch the good fstab line and then use it wherever you like. – X.LINK Oct 17 '14 at 13:23
  • Yeah... the problem is if I add anything at all to fstab it doesn't boot properly. – johnildergleidisson Oct 17 '14 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.