2

I cannot get my FTP server to start, I have checked by using top and it does not show up. When I use sudo /etc/init.d/vsftpd restart I get this "Stopping FTP server: No /usr/sbin/vsftpd found running; none killed. vsftpd. Starting FTP server: vsftpd."

When I run sudo vsftpd I get this "500 OOPS: config file not owned by correct user, or not a file"

I tried sudo chown michael /etc/vsftpd.conf as when I run sudo chown michael /etc/vsftpd/vsftpd.conf I get the no such file error. But I still cannot start the server.

Am I asking this is the wrong place?

2

root is suppose to own vsftpd.conf

sudo chown root /etc/vsftpd.conf

Then try starting the sevice again

  • After doing that I now get this error "Stopping FTP server: No /usr/sbin/vsftpd found running; none killed. rm: cannot remove ‘/var/run/vsftpd/vsftpd.pid’: Permission denied" – Michael St Clair Oct 16 '14 at 16:49
  • 1
    A restart in most scripts performs a stop operation and then a start operation. If the process is not already running, you may get errors (like those you listed) when it tries to stop the service. Is the process running now? – Omnipresence Oct 16 '14 at 17:14
  • No, I have tried just the start command, and the I try restart and have the same issue – Michael St Clair Oct 16 '14 at 19:07
  • Now I just get this error "Stopping FTP server: No /usr/sbin/vsftpd found running; none killed. vsftpd." – Michael St Clair Oct 16 '14 at 19:08
  • 1
    What happens when you run sudo /etc/init.d/vsftpd start ? If you see no output, you should at least be logging to /var/log/rcvsftp.log so you can check that file for information about the startup. – Omnipresence Oct 16 '14 at 19:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.