I am having the problem described in this related question and this one.


When I have a tmux pane that outputs a serious amount of text, tmux becomes unresponsive. All tmux commands are ignored until the text finishes.

This was fixed in tmux by introducing the options:

c0-change-trigger - Number of control characters that occur in 1 ms to trigger throttling
c0-trigger-update - Time to wait between pane redraws when triggered


I am using tmux 1.8. I set the following options in my ~/.tmux.conf file:

# Limit character spewing
set -g c0-change-trigger  100  # default is 250 triggers/millisecond
set -g c0-change-interval 1000 # default throttle updates at 100 ms intervals

However, tmux still chokes on an excessive amounts of text. For example, if I go to a pane and type:

find /

The command generates lots of text and tmux doesn't let me switch panes, switch windows, detach, etc even with the c0-* options set.

I understand that you can see the options that are set by typing:

Ctrl-<Prefix> : show-options -g

In the list, I see options I set in my conf file. However, the c0-* options are not listed. So I can't verify that I have correctly set the values.

I tried intentionally misspelling the options, but I didn't see any error text. So, I don't trust that the options are being accepted.

How do I verify these options? And am I doing something wrong here?

1 Answer 1


Those options are window options, so you need show-options -gw (or show-options -w if they have been customized for a particular window).

The confusion probably comes from the fact that while set-option -g is ostensibly just for setting session options, it will also accept window option names (i.e. for convenience you can omit the -w that would otherwise be required when setting a window option).

If you care to document this distinction you might want to use set-option -gw … (or set-window-option -g …) when adjusting window options.

  • 2
    See show-options [-AgHpqsvw] [-t target-pane] [option] in the tmux man page. Commented Nov 10, 2020 at 10:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .