0

Using tramp / dired-mode to access a remote shared Centos linux server -- e.g., (find-file "/ssh:lawlist@12.34.56.789:/home/lawlist/") -- I have not been able to subsequently copy files / directories recursively from the remote server to the local machine with dired-do-copy. The variable dired-recursive-copies is set to always -- i.e., (setq dired-recursive-copies 'always).

What happens is that the directory selected gets copied from the remote to the local, but nothing inside the directory gets copied over -- i.e., an empty folder is created on the local machine (which has the name of the folder that was copied), but nothing else happens.

How, please, can files / folders be copied recursively from the remote server to the local machine using dired-mode?


EDIT (October 16, 2014):  An Emacs bug report regarding this issue has been submitted -- bug#18751: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=18751

1

Sounds like a bug. If this should recursively copy the directory contents and it does not, then M-x report-emacs-bug, preferably with a recipe to repro that starts with emacs -Q.

FWIW, I just tried it (in my setup), and it worked as you expect (did not fail as you reported). So it sounds like something might be amiss with your setup. I'm on MS Windows - perhaps that makes a difference. Maybe check the permissions of the directories etc., also.

  • Thanks for the suggestion -- with emacs -Q, dired-do-copy is failing on the first hidden file it encountered: Copy '/ssh:lawlist@12.34.56.789:/home/lawlist/wcnsql' to '/Users/HOME/Desktop/wcnsql' failed: (file-error Opening input file no such file or directory /ssh:lawlist@12.34.56.789:/home/lawlist/wcnsql/.www.my.cnf) The permissions are -rw-r--r--. Any way to include hidden files when doing dired-do-copy? – lawlist Oct 16 '14 at 22:37
  • What do you mean by "hidden file"? Is this on Windows, so it means a file with property "Hidden"? Or on GNU/Linux or UNIX, where it might mean a dot file? Anyway, I'm no expert on this. If you think you've found a bug, even a bug in the doc (e.g., it should point out that hidden stuff doesn't get copied), please report it. – Drew Oct 16 '14 at 22:41
  • The shared server where this particular file is located is Linux (Centos). The only thing special about that flat text file, that I can see, is the file extension begins with a dot. I'll submit a bug report. Thank you. – lawlist Oct 16 '14 at 22:46
0

bug #18751 has been fixed by the Emacs development team. The fix is now included in the current version of Emacs Trunk.

Tested with Emacs Trunk built --with-ns on November 5, 2014:

GNU Emacs 25.0.50.1 (x86_64-apple-darwin10.8.0, NS appkit-1038.36 Version 10.6.8 (Build 10K549)) of 2014-11-05 on MP.local

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.