8

The Firefox homepage is now displaying a game with 'Click Me' call to action button. How to change it back to normal (previous) homepage?

Firefox Homepage Game

  • 3
    I highly suspect this is only happening to you since I use Firefox and have not notice this behavior which means we need a screenshot of the behavior. – Ramhound Oct 16 '14 at 18:39
  • Well, it is happening to me; here is a screenshot. – G-Man Oct 16 '14 at 18:45
  • 1
    From the menu: Edit | Preferences | General tab ; paste the URL of your home page in the homepage box. – fixer1234 Oct 16 '14 at 18:55
  • 4
    @music2myear: Wow, the guy who started that support ticket really has no idea that 8-bit or keyboard game controls ever existed, huh? – Lightness Races in Orbit Oct 17 '14 at 0:06
  • 4
    best homepage to set: about:blank – Pieter B Oct 17 '14 at 12:45
18

This is by design. Mozilla is supporting a Humble Bundle promotion right now.

Someone asked this question on the Mozilla support forums and received the following response:

That Click Me game is part of the Humble Mozilla Bundle promotion on the default Home Page [about:home], that loads from the Mozilla servers in the "Brand Logo" (DIV) section of about:home. A feature that was first used in Firefox 29 [IIRC] just prior to the start of the Olympic Games.

Also, part of that promotion is addressed in the "Snippet" below the Search Container on the about:home page.

If you want to block the "Brand Logo" section (and the "snippet" below the Search container) from ever being seen again, you can install Stylish and this UserStyle. https://userstyles.org/styles/104673/about-home-hide-snippets-and-hide-brand-logo

Another solution was offered for this as well:

  1. Type about:config into the address bar and press Enter.
  2. To bypass the warning, press the big button labeled "I'll be careful, I promise!".
  3. In the search box, paste browser.aboutHomeSnippets.updateUrl
  4. In the search results, double-click browser.aboutHomeSnippets.updateUrl
  5. In the "Enter string value" dialog, press the Delete key so that there's no text remaining, then press either Enter or the OK button. As a side-effect, only default tips will be displayed below the search box, because new ones won't be fetched from the web anymore.
  6. Type about:support into the address bar and press Enter.
  7. Click the Show Folder button. A Windows Explorer window with your profile folder opens. In that window, open the storage folder, then the persistent subfolder.
  8. Exit Firefox.
  9. Delete the moz-safe-about+home folder.
0

Type about:config in the address bar.

On the first column, find the browser.newtab.url value. Double click it and change it at will. The default value is about:newtab, if you don't know what to write in it.

That being said, you should check and remove any suspicious extensions and plugins (such as toolbars installed by third party software). You should find this as a puzzle piece in the menu button, to the right of the search engine bar.

0

Use www.google.ca/firefox or www.google.com.my/firefox and that will load the customary Firefox start page on Google. One is in Canada, the other is from Malaysia.

  • Did you even read the question before posting? – Alam Dec 3 '14 at 3:58
-1

Change default start page to get rid of Humble

  1. In Mozilla Firefox address bar write for example Google.com

  2. Go to Options, choose General, click on Use Current Page

  3. Then click OK

From now on you will have Google.com as START PAGE and get rid of looking at the stupid Humble start page !!!

  • 2
    Two other answers have already explained how to change the Start Page to something else. These (including yours) do not answer the question, which asks how to get back to the normal Firefox Start Page. – G-Man Oct 17 '14 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.