0

I am using FireFTP 2.0.21 plugin on Firefox 32.0.3 to transfer files from PC to an Agilent E4438C Signal Generator. The instrument is connected via network switch to the PC.

There is no problem browsing the remote directories and copying files around. However, when idle for some time (a few minutes), I start getting an error message repeatedly. The log console of FireFTP shows:

       NOOP
500 Command not understood - shazbot!

and I get a popup messagebox with the same error message:

enter image description here

  • Why do I keep getting this error message?

  • What is wrong with the NOOP command (which is what triggers the error)?

  • Why does FireFTP repeatedly send this command?

As for the last question, I imagine it is done in order to keep the connection open and not time-out. If so, can it be disabled or changed frequency? At least, can I prevent this annoying popup window?

2

NOOP is the No Operation command. It's used as a keep-alive kind of heartbeat. You might be able to find some settings in your client regarding a keep-alive or maintain connection, etc.

2
  • Thanks. That's what I mentioned in my question. Unfortunately, I could not find a setting in the FireFTP options dialog. – ysap Oct 16 '14 at 20:24
  • Actually - I found one in a 2nd look - "Keep connection alive while idle" option in the "Connections" tab of the "Options" dialog. – ysap Oct 16 '14 at 20:26
0

In a second look at the FireFTP options, I found the setting to disable this repeated "NOOP" command:

enter image description here

However, it is not clear to me why the "NOOP" command is not understood by the server. Isn't this a standard FTP command?

1
  • 1
    Your signal generator might be rejecting this command on purpose because it would interfere with it's power management. – Mr. Mascaro Oct 16 '14 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.