2

Recently I installed Linux Mint 17 Qiana with Mate desktop, downloaded from the Linux Mint website. All works fine but I am not able to create new user in "Users and Groups" GUI tool.

  1. Opened "Users and Group" GUI from menu. Default "Users" tab is selected.

  2. Clicked on "Add" button "Add User" window appeared with following fields "Account Type", "Full Name", "Username".

  3. Entered "Account Type" as "Standard", "Full Name" as "Newuser" and "Username" as "Newusername" and clicked "Add" button but the window is not responsive.

  4. On googling I found "useradd" command. Tried the following command useradd "Newusername" -p "12345". Closed and opened the "Users and Groups" GUI and I can see "Newusername" in the Users list.

  5. Selected "Switch User". Tried to login "Newusername" with the give password "12345" but the system shows up "Wrong Username or Password" error.

Note : I have run update manager and installed all the update. Update manager now shows message "Your system is up to date"

Can any one help make work "Users and Group" GUI and access the user account created from command line.

0

Retry using the GUI but this time put an all-lowercase username in on the first try.

  • Can you explain why this might work? If not, this looks like a suggestion; a guess. That isn't really enough to qualify as an answer on Stack Exchange (Super User). To leave a friendly suggestion to an author, leave a comment below their post – you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – G-Man Mar 28 '15 at 0:32
  • Explaining why it might work gets into the history of development of the operating system. As to why I think it's a reasonable answer, that's because I made an effort to reproduce the issue described in the question, succeeded, and doing this fixed it. I could have included more detail, but thought a concise answer would be appreciated. Of course, since I can't guarantee the setup is the same, I can't guarantee the suggested solution will work. – WBT Mar 28 '15 at 3:49
0

Workaround:

As root, you should be able to run

passwd Newusername

and change the user’s password without needing to enter the current password.

BTW, while it’s often a good idea to quote strings in shell commands, it’s not really needed for simple alphanumerics.  It is necessary for arguments that contain special characters like space, Tab, *, ?, (, ), etc.  It is strongly recommended when referencing shell variables.

The answer

As stated in useradd(8), the parameter to -p is

The encrypted password, as returned by crypt(3).

So 12345 is not an appropriate parameter to -p.  Ways to generate an appropriate value (and other workarounds) are discussed in How to automatically add user account AND password with a Bash script? and Ubuntu Linux useradd with -p option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.