1

localhost points to /Libary/WebServer/Documents. If I have an index.html file in there it opens, no problems. However if I remove the index file it gives me a 403 error instead of showing the directory listing - same applies for all subfolders.

Just upgraded to Yosemite, MBA.

How can I get it to show directory listings again?

-Cheers

2 Answers 2

8

open "/private/etc/apache2/httpd.conf" in an editor. Scroll down until you find this part:

<Directory "/Library/WebServer/Documents">

Inside there you'll need to add "Indexes" to your "Options". For me, this meant changing this line:

Options FollowSymLinks Multiviews

To:

Options Indexes FollowSymLinks Multiviews

Then restart apache:

apachectl restart
1
  • Hot to get permission for textEditor to modify file? Aug 9, 2018 at 11:14
0

Perfect! it worked for me.

Why "Indexes" ?

Indexes If a URL which maps to a directory is requested, and there is no DirectoryIndex (e.g., index.html) in that directory, then mod_autoindex will return a formatted listing of the directory.

Ref - http://httpd.apache.org/docs/2.2/mod/core.html#options

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .