2

I've been running Mac OS X + VMWare Fusion for a long time, with no problems what so ever. But earlier today I upgraded to Mac OS X Yosemite, and after that VMWare didn't want to start my virtual machines. Since I was on a rather old version of Fusion (5.0.5) I decided to buy the new Fusion 7. No problems occurred during installation, the virtual disks was converted to the newer format and started without any errors or notifications.

However, after either the move to Fusion 7 or the conversion of the virtual disks, I have one (!) weird keyboard mapping that I can't figure out how to reset. On my swedish keyboard, all special characters work - except one mapping. The key for < now gives me § and the shift-equivalent > is the shift-equivalent of § which is ½. This is pretty troublesome, since I work as a programmer - and I'm pretty used to typing these characters.

What can I do to reset the keys to their original place?

3

Seems like a bug introduced in Fusion 7: https://communities.vmware.com/thread/488935

This solved it for me, in VMWare Fusion Version 7.1.0 (2314774):

Settings for the virtual machine -> Keyboard & Mouse -> Edit Profile -> Key Mappings -> check "Enable Language Specific Key Mappings"

| improve this answer | |
1

Try these things it may solve your problem. The problem you are facing might be because of changing your regional language while upgrading the OS, you are not the one see this discussion for more info.

https://communities.vmware.com/thread/458726

Set Key Mappings on the Keyboard and Mouse Preferences Pane You can map certain key combinations on your Macintosh keyboard to keys on your virtual machine. The following mappings are supported:

  • Key to Key
  • Set of Modifiers to Modifier
  • Set of Modifiers + Key to Key

    You cannot stack key mappings. You cannot create one key mapping and include that key mapping as part of another key mapping. Procedure

1 Select VMware Fusion > Preferences and click Keyboard & Mouse.

2 Select Enable Key Mappings.

3(Optional) Select Enable Language Specific Key Mappings if you want to incorporate key mappings related to the keyboard layout for the language you selected in the Input Menu (as shown by the flag icon in the menu bar). When you change the Input Menu to a supported keyboard layout, additional key mappings are appended to the key mapping list. Currently, VMware Fusion supports French and German. This feature is not available for Mac OS X Server virtual machines.

4 Change the key mapping settings. Option Description Turn a key mapping on or off

Click the checkbox to the left of the Mac Shortcut.

Edit a key mapping

Double-click the Mac Shortcut or Virtual Machine Shortcut to change and make that change in the Edit Key Mapping dialog.

Add a key mapping

Click the add (+) button and define the new key mapping in the Edit Key Mapping dialog.

Delete a key mapping

Select the key mapping and click the remove (-) button.

Restore the default settings

Click Restore Defaults.

source

**Or Try **

changing regional language preferences. See this for details how to do that. how to set regional language in mac os

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.