85

My question is: How to set up file sharing correctly, in a home network, with Windows 8/10, so sharing any folder with "Everyone" (File Explorer->Right click on folder->Properties->Sharing->AdvancedSharing->Share this folder) actually shares the folder with everyone, without password, even with Microsoft accounts?

Before you answer, please read on, because the trivial solution does not work if Microsoft accounts are involved.

I have a home network, with Windows 8.1 and Windows 10 machines, all in the same Workgroup. No Homegroup. I want to be able to share individual folders on the network, by setting them to shared through File Explorer. In Windows 7 and Vista, I just go to Network and Sharing Center, enable file and printer sharing, disable password protected sharing, and it all works. In Windows 10 and Windows 8, the same still works, but only if both machines use local accounts. As soon as one of the machines - either the one accessing the files or the one sharing them - uses a Microsoft account, it is no longer possible to access any files or folders on the other machines. Specifically, if the machine with the Microsoft account tries to access the machine with the local account, it will prompt for a username and password, and access will fail unless username and password of an actual user on the target machine are provided. Changing the Microsoft account to a local account immediately fixes the problem, with no other configuration changes.

This problem is real, and I've reproduced it on several machines, had friends encounter the same problem, and I've found several reports of other users with the same issue, but no solution. The problem seems to be the same in Windows 8 and in Windows 10.

Successfully implemented workarounds (not solutions):

  1. Store the usernames/passwords to the other machines in the Credential Manager and give up the idea of sharing without password. Best use a common account for access*.
  2. Don't use Microsoft accounts.
10
  • 1
    Have you tried granting the ANONYMOUS LOGON identity permission to your shared folder? Dec 31, 2014 at 21:22
  • 1
    I have since tried allowing the anonymous logon on the machine with microsoft account, no luck accessing it from a machine without. I'm not using a homegroup because machines and networks change(e.g. LAN party), and setting the homegroup up time and time again is too annoying to consider.
    – Peter
    Jan 3, 2015 at 1:10
  • 1
    I can't recall a time, using any windows version, when I shared a folder on one machine and was able to access it over LAN without any issues. There is always some sht going on, be it domain; workgroup; or this permissions sht... come on already.
    – Ejaz
    Jan 28, 2016 at 5:51
  • 3
    And with the latest Windows 10 update, Microsoft has broken this AGAIN. Now, it won't work with local accounts either. Why are they waging war against anonymous shares? Some people WANT them!!! Jan 22, 2017 at 22:48
  • 1
    as a variation of a workaround 1, you can add to credential manager "BLABLA\Guest" account with blank password. BLABLA can be anything, as far as I can tell
    – Ubeogesh
    Dec 10, 2023 at 11:12

3 Answers 3

23
+25

To explain the problem :

On Window 8.1, and presumably Windows 8, when using a Microsoft account to login to Windows, the default user-name when you make a network connection is MicrosoftAccount\<live_id_username>, instead of the login <computer_name>\<username> as in previous versions of Windows.

This MicrosoftAccount form is likely to cause a login failure on any server that is not using a Microsoft account, due to the strict way that Microsoft/Local accounts are implemented in Windows 8/8.1.

I have not been able to find a way of forcing Windows 8/8.1 to use the old format of computer-name\user-name, unless with one of the workarounds you have listed in your post. Probably this problem needs to be addressed by Microsoft itself.

I have tested and this is still true in Windows 10, so don't expect any improvement. Unfortunately, this is just the way that Microsoft/Local accounts were implemented.

10
  • I have since duplicated the problem with Windows 10 and have tried every workaround mentioned on the Web, to no avail. I can see that the prompt dialog has the Windows 10 computer itself as the domain, and the only way to change this is to enter <computer-name>\<username> in the dialog. I still don't know, as in my answer, any other solution than the workarounds you have listed in your post. You could raise this issue in the Windows 10 feedback channel.
    – harrymc
    Jan 1, 2015 at 11:13
  • 1
    Since I asked the question, 10 months have passed and there have been 15000+ views. Nobody knew how to fix this, so I'm marking this as the answer, to acknowledge that network sharing is partially broken in Windows 8 and 10.
    – Peter
    Sep 7, 2015 at 7:43
  • I have a problem with sharing my local folder (Windows 10) with another Windows 10 PC. But that other Win 10 PC has Microsoft account, and I can access its share without password. I cannot confirm your conclusions. Oct 19, 2015 at 9:21
  • 1
    Just tried again, still not working Nov 25 2015.
    – Peter
    Nov 25, 2015 at 11:06
  • 2
    Still not working on Windows 10 Anniversary update Oct 1, 2016 at 3:40
48

I managed to share folders without passwords in Windows 10 with Microsoft Accounts by following this guide: http://www.howtogeek.com/126214/how-to-create-network-file-shares-with-no-passwords-in-windows-8/

I publish here in order to prevent link rot:

  1. Open Network and Sharing Center
  2. Then click on the Change advanced sharing settings Link in the left hand panel. screenshot
  3. Now expand the All Networks section. screenshot
  4. Finally switch the radial button to the Turn off password protected sharing setting and click Save changes. screenshot
  5. It works!

I did not try this extensively (for example if you need to have a password protected share instead), as all the shares in my LAN don't need to be password protected, and since there's no wifi, I know that i'm the only one to access the share. But I think, if it disable all the passwords, it will still work with NTFS access permissions

9
  • 6
    This is the exact solution that the question says doesn't work, except this one forgets to mention that you also need to enable file and printer sharing in the same window. I just verified on some machines to be sure this is still the case: Accessing a shared folder on a machine with microsoft account from a machine with local account still does not work this way, without some form of additional shared credentials - even with the latest patches of windows 10 on both machines.
    – Peter
    Nov 25, 2015 at 10:58
  • 2
    For me it works. Shared a folder on Win10 with a Microsoft account and "everyone" permissions, it can be accessed from anyone without a password (Tested on XP-7-8-10) Nov 30, 2015 at 12:19
  • 3
    @Magnetic_dud The problem is the other way around. If the current user is a Microsoft account, it can't access shares on other Win10 machines. Relog to a local account and the share on the other machine is suddenly accessible.
    – cremor
    Dec 23, 2015 at 18:54
  • 4
    This did not work for me on win 10 & win xp. :( I am guessing, because Windows 10 disabled GUEST account, and can not be enabled no more.
    – Kyslik
    Oct 2, 2016 at 18:11
  • 4
    You need to grant the Everyone identify permissions to the folders you have shared. Further, if you want users to be able to modify folders over the network, you need to edit the Share permissions and make sure 'Everyone' has Full Control. Apr 20, 2017 at 19:08
0

I am able to use a share over 2 PCs with Windows 10 v22H2 here.

Main PC creates the share, using a local administrative account:

  • Right click on the folder to share, Properties -> Share tab -> Advanced sharing... button.
  • Tick the Share this folder mark, then set the Share name, optionally enter a comment
  • Press the Permissions button, then tick the checkmark on Full control for the Everyone group.
  • Now go to the Security tab and press the Modify... button
  • Press Add..., then type Everyone on the next window and press OK
  • Tick the Full control checkmark on the Permissions for Everyone groupbox on the bottom

The next steps could be needing a Windows 10 Pro license to access the Administrative Tools:

  • Press Start, type secpol.msc and press Enter (or go to Control Panel -> Administrative Tools (Windows 10) / Windows Tools (Windows 11) -> Local security Policy)
  • On Local Policies -> User Rights Assignment -> Deny acces to this computer from the network: Remove Guest
  • On Security Options -> Network access: Shares that can be accessed anonymously: Enter the share name here, exactly the same as you set in the Advanced Sharing -> Share name (NOTE: I don't know what needs to be done for multiple shares, I have a single share with public access)
  • On Security Options -> Accounts: Guest account status: Activated

Secondary PC accesses the share:

Open Explorer -> Network. Some seconds and the main PC appears, I double click on it, I see the share, double click on it and I enter it without entering any credentials. This both using a local account and a Microsoft account.

I think that's all. I installed Windows 10 v22H2 on both computers a couple of weeks ago, so any other setting should be to the default set by the Windows 10 installation. During the installation I removed the network cable, so I completed the installation using a local account. Feel free to ask in the comments any other setting, should this guide not work for you.

1
  • On my new Windows installation, the option for the last point ("") was "Not defined" and disabled (greyed out). I enabled the guest account by starting cmd as Admin, then entering command "net user guest /active yes".
    – JRA_TLL
    Jan 3 at 12:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .