I have installed git on windows from http://git-scm.com/download/win and I use the Git Bash shortcut to access git commands.

Unfortunately, Git Bash uses the Windows Command (CMD.EXE) Terminal which is horrible to work with.

How can I change Git Bash to use mintty instead of CMD.EXE?

  • 1
    Note that the installers for current releases from git-scm include an option to use mintty OR cmd as the terminal
    – pb2q
    Jan 17, 2016 at 17:50
  • For a long time now git-scm has installed a much nicer Terminal. For example, now you can resize it horizontally.
    – geneorama
    Mar 16, 2016 at 13:36

3 Answers 3


Head over to http://code.google.com/p/mintty/ and download the latest zip file containing the mintty msys package. As of 18 Oct 2014, the latest version is mintty-1.1.3-msys.zip

Extract mintty.exe from the zip file and copy it to the bin folder where you installed git. If you installed git to the default location, the path is C:\Program Files (x86)\Git\bin

Next right click on the windows shortcut for Git Bash. Change the target to: "C:\Program Files (x86)\Git\bin\mintty.exe" /bin/sh --login -i. If you installed git to a different location, you will need to use your installed path.

Now clicking on the Git Bash shortcut should open mintty.

  • I tried this approach. Modifying the Git Bash shortcut worked and that opens a Mintty terminal, but modifying C:\Program Files (x86)\Git\Git Bash.vbs by copying and pasting your version has not modified the behaviour of Git Bash within the context menu - Git Bash still opens with cmd.exe in this case: puu.sh/ddSW0/5efa2f5c42.png puu.sh/ddSWG/91e68d1790.jpg
    – Tagc
    Dec 2, 2014 at 9:54
  • Apologies - that part of the instructions were provided by another stackoverflow user so I have removed them.
    – Chris Snow
    Dec 2, 2014 at 11:02
  • No problem, going through the Git Bash shortcut suffices for now and being able to use Mintty more than makes up for the trouble, cheers.
    – Tagc
    Dec 2, 2014 at 11:57
  • That Google code archive is really out of date! Please update your comment.
    – jcollum
    Aug 17, 2017 at 23:37

Since 2017 the most elegant solution is wsltty from the developer of mintty. It's mintty as a terminal for Bash on Ubuntu on Windows / WSL.

Just download and execute the installer.


Try reinstall git and:

  1. Uncheck "Only show new options"
  2. Choose "Use MinTTY" instead of the default one

enter image description here

  • 1
    This was useful for me as I noticed the root cause of having two different versions of git bash on 2 different systems Apr 7, 2022 at 13:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .