6

Every time I try to boot my system which runs on windows XP, my PC does not start and I have to press F10 to go to BIOS set up mode and under advanced option, I have to select IDE (in default mode, it shows RAID), and after saving it by pressing F10, the PC boots up. How do I resolve this problem?

Further, It seems my CMOS battery is dying as my PC does not show correct date and time recently.

4
  • 8
    Buy a new CMOS battery. – Tetsujin Oct 19 '14 at 8:36
  • Classic symptoms of a CMOS battery not holding enough charge to keep your "user defined" BIOS settings. @Tetsujin: make that an answer. Without a doubt that's the problem. – Kinnectus Oct 19 '14 at 8:43
  • it seemed a bit terse for an answer, though I see no other reason for the symptom, given the OP's explanation ;-) – Tetsujin Oct 19 '14 at 8:46
  • Why do you even bother asking a question? The answer really is staring you in the face and you know what it is. Get a new battery. Job done. – spender Oct 19 '14 at 21:54
16

As @Gaurav Joseph already wrote, the problem is caused by the BIOS battery.

Some background:

In order to access a disk you need the right drivers. In the past those drivers were loaded before you could start installing.

Eventually the disk controllers and disks in most PC type computers standardised to something called IDE or ATA. Windows XP (and other operating systems) took advantage of this and added the most common drivers to their OS. If you used something to new or something unanticipated (e.g. a RAID card, many SCSI drivers, …) then you still need to load the drivers for that.

This could be done after installing the OS on a supported disk, or by pressing F6 and inserting the floppy with the drivers during installation of XP.

Yes, floppy. Old. :)

Back to your computer:

Your computer seems to have a SATA controller and a SATA disk. This is not the same as the classic ATA (also called PATA). You need additional drivers to use that. Drivers which are not on the XP installation CD.

Since this was annoying to most people many computers got shipped with an option to use SATA devices in a legacy (IDE compatible) mode.

All of this means that:

  1. You could set the BIOS to AHCI (that is the normal SATA mode) and install XP with extra drivers.
  2. Or you could set the BIOS to ancient legacy mode and just install XP without bothering with extra drivers.

The person which installed your computer has done the last. This is why your XP will not boot unless the BIOS is set to configure the disk controller in legacy mode.

BIOS.

I Just wrote that in your case the BIOS must be set to legacy mode. The BIOS needs to remember this. It does that by writing this information to a chip which need electricity to keep that information. Either by having the computer turned on, or from a backup battery when the power is turned off.

If this backup battery is empty then the BIOS will loose its stored configuration when you turn the computer off. Usually this means it will return to its defaults.

In your BIOS you will find three options for the SATA controller:

  1. AHCI
  2. Legacy / IDE
  3. RAID.

It appears that the last option is the default. And just like any non-legacy mode XP requires drivers for this.

That means you have two solutions:

  1. Proper solution: Replace the backup battery (and thus keep all BIOS settings intact when the PC is off.)
  2. Add the drivers to the OS allowing it to boot with the default settings.

The latter is not trivial on a boot disk with XP.

1
  • Nice answer: Not just supply the solution, but the background too. And in terms anyone can understand. – Tonny Oct 19 '14 at 10:40
4

Please change your motherboard battery and try saving your settings.

2
  • 5
    This is the right solution, but I feel the answer should explain some more details. – Hennes Oct 19 '14 at 10:05
  • @Hennes, yeah you are right. – Gaurav Joseph Oct 19 '14 at 13:07
0

You can save ur settings as custom settings. Set the settings you wish to make as default and while exiting there should be an option just above the Save and Exit to make BIOS default. Below text is taken from Intel Website. I have tried it myself and it works.

Enter the BIOS Setup Utility by pressing the [F2] key during boot and writing down all of your current CMOS settings. Also, you can go to the Exit menu and choose the Save Custom Defaults options. Choosing Yes causes the current BIOS settings to be saved as a custom default setting.

http://www.intel.com/support/motherboards/desktop/d101ggc/sb/CS-021749.htm

1
  • 1
    Hello - its best to post the full answer here rather than rely on a link which may become unobtainable at some point in the future. – suspectus Jan 15 '15 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.