5

I'm using Windows 10 tech preview.

Anytime I create a junction (using either mklink from cmd or junction.exe here: http://technet.microsoft.com/en-us/sysinternals/bb896768.aspx ), I cannot load it with Windows Explorer, nor does it work with any applications. I used this same technique in Windows 7 and Windows 8 with never an issue.

I get this error:

You don't currently have permission to access this folder. Click Continue to permanently get access to this folder.

Clicking Continue yields this error:

You have been denied permission to access this folder. To gain access to this folder, you will need to use the security tab.

I am the only user, and an administrator. The security tab does not shed light -- SYSTEM, Administrators, and my user account all have full allow permissions on this folder. I have created multiple junctions and none seem to work.

  • This started happening for me as well after the last update. It could be a bug. – Francesco Noferi Oct 20 '14 at 11:43
  • Given that Microsoft has added support for Symbolic Links to the New-Item, Remove-Item and Get-ChildItem cmdlets in PowerShell 5 (and that they could also be adding support for Junction Links), this behavior maybe a side effect of the work in that area. – Windos Oct 20 '14 at 20:43
  • In light of this I will close the question and see if I can dig up any development info. Thanks! – profesor_tortuga Oct 21 '14 at 1:34
1

For me, the issue was not solved with the build 9860. It's just a bit less annoying (it take less time for Windows to free the symlink/junction).

If you want more informations, there is a thread on Technet. I explain which tests I did.

https://social.technet.microsoft.com/Forums/en-US/c4c69272-0329-496e-8c83-05a15d9b284b/problems-with-symbolic-links-whines-about-missing-permissions?forum=WinPreview2014Feedback

Edit 11/14 : Issue seems to be solved with the installation of the new build 9879.

3

This bug was fixed in the newest Build 9860

  • Thanks for the heads up; can confirm, it's fixed for me too – profesor_tortuga Oct 23 '14 at 2:00

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.