1

I am currently trying to extend a small computer network between 2 buildings around 1 km apart. The setup looks like this:

modem
  |
Dlink router 1 - 192.168.1.1 (antenna connected to LAN port)
  |
engenius directional antenna 1- 192.168.1.2 (access point mode)
  |
engenius directional antenna 2- 192.168.1.3 (client bridge mode)
  |
Dlink router 2 - 192.168.1.10 (antenna connected to LAN port, DHCP disabled)

However, I am running into problems connecting any clients from the second router to the internet. Running a laptop from building two, I can ping any client in building 1 except for the first router.

I am no network wizard, and so there's probably something stupid I'm overlooking, but are there any settings that I may be missing to allow clients from building 2 to connect to the internet?

router1 config file

router2 config file

  • 2
    In your config both routers have dhcpcd_enable=1, and what is the default gateway on clients in building 2? I don't like this setup because network broadcast is shared between buildings and thus can slow down the network. I recommend you set each building with a different network and have a static route between them. – Ammar Alammar Oct 20 '14 at 5:26
  • SO if I subnet the network, how would this look? – hyleaus Oct 20 '14 at 23:38
  • Let me ask in another way, given that I have to connect fewer than 15 machines on the whole network, how should I do this? The above config doesn't work. Period. I'm open to any viable solutions. – hyleaus Oct 21 '14 at 0:36
1

You need to set your network as such:

  1. Building 1 router:
    • Client network interface: 192.168.1.1
    • Bridge network interface: 192.168.3.3
  2. Building 2 router:
    • Client network interface: 192.168.2.1
    • Bridge network interface: 192.168.3.4
  3. Bridge network:
    • Building 1 side: 192.168.3.1
    • Building 2 side: 192.168.3.2

Now on building 1 router you should have the route (this is not a proper syntax to add routes but it should give you an idea of what it's doing):

route 192.168.2.0 netmask 255.255.255.0 gateway 192.168.3.4

with DHCP gateway to be 192.168.1.1

And on building 2 router:

route 192.168.1.0 netmask 255.255.255.0 gateway 192.168.3.3

with DHCP gateway to be 192.168.2.1

This assumes each router have at least two interfaces, one for the local network and one for the bridge network.

  • I just checked, and unfortunately I can't seem to set the ip address of specific interfaces on the bridge antennae. However, using the same scheme I previously posted, I seem to be having luck by disabling dhcp (as you suggested) on router 2, and setting the default gateway on engenius antenna to 192.168.1.1 as opposed to 192.168.1.2, which is where I had it. Would this have been the problem? – hyleaus Oct 21 '14 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.