0

RDP Client suddenly stopped logging in to any RDP server.

I'm sure that my credentials are right; I can log in via Remmina on Linux, but can't do it on Windows native TSC.

I tried to remove recently installed update of RDP (KB2592687), but it did not work.

I tried to reset all RDP settings (both Default.rdp and registry branch), but it still doesn't work. I'm sure that ports are open because I can log in via Remmina, but causing authentication error on Windows.

How can I fix my client? Where can I view logs of my RDP client?

It asks me to enter username and password. When I enter them, it says that they are wrong and asks me for them again. This is the window that is displayed:

RDP authentication window.

Sorry for the Russian language; it says, "Log in attempt failed" and it asks username and password again.

9
  • What happens when you try to connect? Are you getting any error messages? Oct 20, 2014 at 16:34
  • When I enter my username and password, I get a message "Log in attempt failed" and it asks username and passwords again.
    – namikiri
    Oct 20, 2014 at 16:36
  • @Ƭᴇcʜιᴇ007 sorry, I forgot to mention you. Please see comment above.
    – namikiri
    Oct 20, 2014 at 16:52
  • You probably have to provide a domain that the username is a member of to authenticate the session. Click "Use another account" where you'll be able to provide a username and password. The username is normally in the format domain\username.
    – Kinnectus
    Oct 20, 2014 at 18:16
  • @BigChris all my computers aren't in domain. They don't use it.
    – namikiri
    Oct 21, 2014 at 18:48

1 Answer 1

0

Problem solved!

There was some wrong settings of firewall of my gateway server.

There was two lines in iptables config that allowed me to access my home computer from external networks:

-A PREROUTING -p tcp -m tcp --dport 3389 -j DNAT --to-destination 192.168.x.y
-A PREROUTING -p udp -m udp --dport 3389 -j DNAT --to-destination 192.168.x.y

I did not specify any conditions (like in/out interfaces and ip addresses), so my server prerouted me to myself and Windows got surprised.

I have commented out these two lines and RDP started to work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.