I installed and used chocolatey in the past on my Windows 7 running in Parallels on Mac OSX.
However, recently, whenever I try to use it from the command prompt I get the following error:
CLR initialization failed with error 800700c1.

I don't think this is a problem with choco itself, but something with the CLR configuration. I couldn't find any solution to this.

I get the same message if I run powershell.
Also, when I attempted "Control Panel->Troubleshooting->Fix Problems with Windows Update" I get an error dialog with the same code.

I also tried repairing and updating the .NET Framework installation, but to no avail.

Update 2 I think it is related to the following DLL: C:\WINDOWS\WinSxS\x86_Microsoft.VC80.CRT_1fc8b3b9alel8e3b_8.0.50727.3053_x-ww_b80fa8ca\MSVCR80.dll. It is apparently corrupted. When I try to open in in depends it gives an error: "No DOS or PE signature found. This file is not a valid 32-bit or 64-bit Windows module."

  • 0x800700c1 = "ERROR_BAD_EXE_FORMAT" according to Winerror.h. What have you tired already in attempts to repair it? Have you tried reinstalling Chocolatey? Checked for disk/file-system corruption? – Ƭᴇcʜιᴇ007 Oct 21 '14 at 16:48
  • @Ƭᴇcʜιᴇ007: Sorry. I added additional info from my ongoing fix attempts. – Adi Shavit Oct 21 '14 at 17:14
  • Do a CHKDSK to see if you have file-system corruption, once that comes up clean run SFC /scannow to ensure all system files are correct. Report back with results. :) – Ƭᴇcʜιᴇ007 Oct 21 '14 at 17:20
  • All return clean. chkdsk: Windows has checked the file system and found no problems. SFC /scannow: Windows Resource Protection did not find any integrity violations. – Adi Shavit Oct 21 '14 at 17:35
  • And the problem still exists eh? Weird. Have you tried in Safe Mode? How about in regular mode, while logged in as a different User? – Ƭᴇcʜιᴇ007 Oct 21 '14 at 17:39

I finally got it fixed.

As I suspected, it was related to a (possibly) corrupt 64-bit DLL MSVCR80.DLL.

I uninstalled all the "Microsoft Visual C++ 2005 Redistributable" packages (both 32 and 64 bit) via the regular uninstall screen from the Control Panel - I had 3 such packages.
After this, everything returned to working order.

  • Can we get someone to mark this as the answer? – ferventcoder Oct 22 '14 at 15:49
  • Gotta wait for a few more hours.... – Adi Shavit Oct 22 '14 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.