I had configured Chrome to save password on one particular website.

But now I don't want Chrome to save it. Naturally, I went to saved passwords from wrench menu and deleted the saved password.

The problem is, whenever I login to that website again, Chrome saves my password again. It's like Chrome thinks that it's supposed to save that password and even if I delete it, it will save it again.

How do I stop this behavior? Is there any way to manually add a website to "Never Saved" list?

2 Answers 2


If you remove the website form the list at Settings - Advanced settings - Password and forms - Managed saved passwordsand then try to log in again, Chrome should prompt you to save password again. Here you should chose Never for this site in the dropdown. This sould work, I just tested it.

Besides this, I have not found any way to manually add a website to "Never saved".

Read more about this subject in the Google Chrome Help.

  • 3
    Unfortunately, the "Never" never works. Next time you are on the page the offer to save password is there again. And will do that time and time again and you need to press the "Never" button every single time!
    – Bogdan
    Feb 16, 2021 at 17:54
  • 1
    I agree with @Bogdan, as of Chrome 102, this still does not work properly. Jun 17, 2022 at 1:37
  • This solution from 2014 seems to no longer work. Removing the site from Chrome's password keeper still automatically saves the password for me with no prompt to save or never save it. Any new solution?
    – Caleb Hawn
    Mar 8 at 13:14

If the popup for Never save password for the doesn't show up, there will be a key logo in the right side of the address bar you can click and it will give you the option to never save the password for that site...

  • 1
    Sadly, this seems to no longer be true. Any new solution for today?
    – Caleb Hawn
    Mar 8 at 13:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .