2

I have next setup:

My home lan = 192.168.1.0/24

My virtual lan = 192.168.207.0/24

My laptop = 192.168.1.109 (dhcp OS=Windows7)

My desktop = 192.168.1.206 (fixed ip OS=Windows8)

My virtual machine installed on the desktop = 192.168.207.128 (NAT + dhcp OS=Linux Mint)

Ping from virtual machine 192.168.207.128 works to all.

Ping from workstation 192.168.1.206 to vm 192.168.207.128 works.

Ping from laptop 192.168.1.109 to desktop 192.168.1.206 works.

Ping from laptop 192.168.1.109 to vm 192.168.207.128 FAILS.

Ping from laptop 192.168.1.109 to vm def gw 192.168.207.1 FAILS.

VM is in nat mode. I know this will be easier in bridged mode. But I want to make it work in NAT mode if possible.

I found 3 reasons for this to fail. And I applied what was necessary (I thought, but without success...).

1/ NAT needs port forwarding. So in the vm network settings I did port-forwarding. Settings are: 'port 22' and 'vm ip address 192.168.207.128' 'type TCP'.

2/ Windows firewall on my desktop can cause problems, so I disabled Windows 8 fw.

3/ My laptop does not know a route to that network 192.168.207.0. So I added a static route in Win7 like this in command line: [route add 192.168.207.0 mask 255.255.255.0 192.168.1.206 metric 1]

Many thanks for your help, or some advice.

  • How is forwarding port 22 supposed to make ping work? It would also help a lot if you explained why you are using NAT mode. – David Schwartz Oct 21 '14 at 22:14
  • Hi David. Port 22 was ment for the ssh connection. Why I want to use NAT mode is just for the challenge. I wanted to do some experiments. Beginner networking. – maxim Oct 22 '14 at 6:46
1

You are asking your Desktop PC to become a router between the 192.168.1.x network and the 192.168.207.x network.

Windows doesn't do this automatically, it needs to be enabled. Go to Start, then type services.msc in the run box.

Open services, and find the Routing and Remote Access service. It will be disabled. Go to the properties of the service, enable it and start it (automatically if you wish).

| improve this answer | |
  • Hello Paul. Thank you for your input. I'll try this at home this evening. – maxim Oct 22 '14 at 6:49
  • @max You accepted - did it solve the problem or was sonething else needed? – Paul Oct 23 '14 at 7:04
  • Hi Paul. I found your service. It's well explained how to get there. The only problem is that I receive an error when activating that service. I'm changing my plan here and will go through 'bridged' mode. Like I said to David, it was just for a test. Also I'm not sure I want my desktop pc to function as a router. Anyway thanks having clarified this for me. – maxim Oct 23 '14 at 7:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.