7

I installed teamviewer from terminal by following this guideline ; link

But if I run teamviewer --info (with sudo or not) it shows

 TeamViewer                      9.0.32150 

 teamviewerd status              teamviewerd start/running, process 2639 

 TeamViewer ID:                   
Try restarting the TeamViewer daemon (e.g. teamviewer --daemon restart)

As the warning suggests I restarted teamviewer but the problem is still exist.

Do you have any idea about this?

  • Same problem in CentOS 6 – e-info128 Mar 24 '15 at 4:17
  • This question is almost a year old. It has some diagnostic advice and a speculative solution posted as answers. Can you update the status? Did you solve it (in which case can you post your solution as an answer)? Was it overtaken by events and no longer an issue (if it's no longer reproducible or solutions can't be tested, the question should probably be closed)? Are you still looking for a solution? Thanks. – fixer1234 Sep 20 '15 at 22:20
9

Try setting your password first. teamviewer --passwd newPassword. I encountered the same issue, it wasn't until after I set a password that teamviewer -info showed me an ID. Perhaps it was coincidence.

  • Nathan, I tried many things, even reinstalled different versions of TeamViewer. This is what finally worked. Bit odd though. But works :) Thanks! – Arun Das Dec 4 '18 at 20:06
0

This issue might be due to several reason. Please check the log for further information using the below command

grep -o "id=[0-9]*" /var/log/teamviewer/TeamViewer8_Logfile.log

If you are having any permission issue, then just execute the below command

grep -Ro "id=[0-9]*" /var/log/teamviewer/TeamViewer8_Logfile.log

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.