3

In the past I've used VoIP/SIP apps to call from my Android phone. Recently I got the upgrade to Android KitKat (4.4.x) and I've noticed that it includes SIP accounts natively (accessible through calling app, settings, SIP accounts). It didn't work though: either the connection timed out or authentication failed, no matter what I try.

The only settings I have are a username (626) and a password. How do I configure Android to use this?

4

After about an hour of searching and debugging I've found the answer:

The FritzBox password can only be digits.

For future reference, these are the complete steps:

  1. Create a new telephony device here: http://fritz.box/fon_devices/fondevices_list.lua (you will need to log in to your router). Choose Telephone in the first step and LAN/WLAN (IP telephone) in the second step.

  2. Pick a random password that is only numbers. Advised length is 16 digits because hackers can guess numbers more easily (a strong password should have letters, but the FritzBox cannot do that with for VoIP/SIP).
    Tip: after entering the password in the fritzbox, copy it to notepad and format the numbers into groups of 5 to make them easier to type into your Android device.

  3. Using 16 random digits, you can safely enable the "Allow registration from the Internet" feature in the "Account Information" tab in the FritzBox.

  4. Look your IP address up using a site like http://whatismyipaddress.com

  5. Select "Receive incoming calls" in Android, even if you disabled it in the FritzBox. This is temporary and makes it easier to test.

  6. Use the settings (the important settings are bold):
    Username: 626 (or whatever account number you got)
    Password: your password (numbers only!)
    Server: your IP address
    Authentication username: not needed
    Display name: as you like
    Port number: 5060 (default)
    Transport type: TCP
    Send keep-alive: Automatic (default)

  7. Press save

  8. If you enabled "Receive incoming calls" in step 5, then the device will now try to register so that it can start receiving incoming calls. You will see the account status change (we're still in the "SIP accounts" screen).

  9. When it reads "Receiving calls", it means it is currently ready to receive calls. This means it could contact the server and the login worked.

  10. You can now, if you want to, disable "Receive incoming calls".

Calling via this internet account should now work!

Troubleshooting at step 8:

  • If it reads "timed out", you probably mistyped the IP address or DNS address. And make sure that the transport type is set to TCP. If it's set to TCP already, try UDP instead, but it's probably TCP. You can also try using fritz.box instead of the IP address, but that will only work at home (not elsewhere).

  • If authentication failed, you used a password with letters (or spaces or something else). Or you mistyped it. Or you have the wrong account number. Or maybe you mistyped the server's IP address (you might be logging in to the wrong FritzBox!).

Note: If you have a dynamic IP address (an IP address that changes every few days), you will need to use a dynamic DNS service. I have a static IP address (you can sometimes request them for free at your ISP) so I don't know which ones are good nowadays, but there used to be plenty of free ones out there. In this case, use your DNS address instead of your IP address as server in step 6.

5
  • UDP works on 7360 model FritzBox with Android 5.1.1 (tested internal only, i.e., fritz.box as server). The on-line knowledge base (en.avm.de/nc/service/fritzbox/fritzbox-7360/knowledge-base/… for my model) does not mention number-only password, but that did the trick.
    – equaeghe
    Sep 2 '15 at 7:50
  • With the MyFRITZ! service from AVM (en.avm.de/nc/service/fritzbox/fritzbox-7360/knowledge-base/…) it works through the fritz.net dynamic DNS, but now only with TCP.
    – equaeghe
    Sep 2 '15 at 8:32
  • Well, I tested the both direction of the connection by calling, but without actually picking up. Now that I tried that, it turns out the call is dropped at once at this point. So it seems that there is more going on than just what you and I wrote.
    – equaeghe
    Sep 2 '15 at 20:13
  • Once I stopped calling from my phone using the mobile connection to my the same phone using the SIP connection, things improved. Only over-the-internet connections still have problems: android.stackexchange.com/q/122315/124768.
    – equaeghe
    Sep 5 '15 at 19:59
  • UDP is the only thing that works for me when calling from the android device, but connection seems really unstable. After ending a call, it will some times fail to register with the fritzbox for a longer period (timeout). My fritzbox is the 3370 though. Only using it for in-house calls. Dec 13 '15 at 22:38
1

I saw the same problem with the FRITZ!Box 7490 and a Samsung S4 (Android 5.0.1), Samsung S7 (Android 7.0) and Sony Xperia (Android 6.0.1).

Username: however had to be the username given for the ip telephone device. The 3 digits 621 didn't work.

Password: It didn't make a difference wether the password had only digits or also other characters.

Server: fritz.box

But still registration timed out. Also the CSipSimple app failed.

However I got VOIP/SIP working with the apps Fritz!App Fon, Zoiper Lite, Zoiper Beta and GS Wave. Zoiper seemed the most advanced with Bluetooth support and auto recording.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.