9

How do I configure proxy settings for Chrome on Linux? It doesn't have a configuration interface like Firefox. I'd like to configure it in a way that I don't have to type every time, the login and password.

EDIT: I'm using Fluxbox as my window manager.

6

Try the --proxy-server command line option, and/or http_proxy environment variable.

google-chrome-stable --proxy-server="http://example.com:8080"

Also, Chrome/Chromium makes use of xdg scripts, so you can try configuring the proxy server in GNOME/KDE, and set up xdg scripts to use settings of the desktop environment. That is how I solved MIME-type file associations at least.

  • Calling the google chrome executable with the --proxy-server parameter worked fine, thanks. When browsing it pops up an authentication screen for every tab from the last session, is there a way to 'remember' the login and password, or make it authenticate automatically? using the --proxy-server parameter like --proxy-server="username:password@proxy-ip:port" didn't work. – liewl Dec 14 '09 at 17:55
  • 1
    'google-chrome --proxy-pac-url=file:///...' works perfectly. There's no need to use http_proxy this no_proxy that. If you've got a pac file for use with firefox it'll work fine here. If you need help writing a .pac file google is your friend... But you can still configure via the command line. Please see man google-chrome for more information on flags and environment variables. – RckLN Aug 8 '13 at 18:28
  • Re the username and password auth in chrome using the --proxy-server parameter - this appears to be a bug in Chrome - please star the issue here: bugs.chromium.org/p/chromium/issues/detail?id=615947 – hawkeye May 31 '16 at 10:20
  • How does one enable and disable the proxy connection within a running chrome instance? – Fopedush Jun 7 '16 at 16:33
2

run this as root gedit /usr/share/applications/google-chrome.desktop then add your proxy settings as you would like ie --proxy-server="http://127.0.0.1:8080" then save and run chrome .

  • Can you explain how this works? – bwDraco Oct 2 '15 at 19:20
  • that's editing the chrome's app settings, so as to pick them during start. – Patrick Mutwiri Oct 3 '15 at 0:37
  • Instead of gedit, you can use whatever text editor you want, as 'vi' for example – pocjoc Nov 21 '17 at 7:52
  • Ofcourse @pocjoc – Patrick Mutwiri Nov 29 '17 at 6:54
2

On Ubuntu 16.04 LTS with Chrome v53 (64 bit), I had to set the http_proxy / HTTP_PROXY env variables to "http://proxyserver:port" for all users for Chrome to be able to communicate.

Modify /etc/profile

export {http,ftp,https,rsync}_proxy="http://proxyserver:port"
export {HTTP,FTP,HTTPS,RSYNC}_PROXY=$http_proxy
1

Chrome uses the Proxy settings for your DE. If you use KDE it will use this. If you use Gnome it will use theirs. If you don't use either, I think it will try to use Gnome's, but not 100% sure.

If you go the the Wrench -> Under the Hood , you should have a button under Network labeled Change proxy settings. When I click this, in my case, it loads KDE Proxy settings.

If you don't use either KDE or Gnome, you could try browsing gconf , Chrome uses it to store it's settings.

  • How should I proceed under Fluxbox? Do I have to set the proxy for the whole system? – liewl Dec 14 '09 at 17:56
  • Did going to the settings under the Wrench give you the option to Change Proxy Settings? – Ryan Gibbons Dec 14 '09 at 20:20
  • Nope, it shows a page giving explanations of possible ways to set up proxy configurations. Apparently i'd have to change the proxy settings on the OS itself, i'd like to set it only for chrome. – liewl Dec 15 '09 at 0:34
  • Doing a bit more reading out of curiosity, chrome either uses the system proxy or through the command switch. But now way to remember the username / password – Ryan Gibbons Dec 15 '09 at 3:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.