4

Yesterday, I went home with Git working perfectly well inside Visual Studio 2013. I could 'Compare with unmodified' for a source file, I would see the version control status of my source files, and all the goodies of Git inside Visual Studio. I shut down my computer when I left work yesterday.

However, when I came to work this morning, as soon as I launched VS, I got this strange message from Git Version control saying,

'Path 'C:\' doesn't point at a valid Git repository or workdir.' 

I proceeded to opening my project which is under Git version control, and strangely, Git did not recognize my project - None of the source files seemed to be added to version control, all the options such as to compare with unmodified version of a file were missing, it was as though the project was never under Git version control.

So, I did a system restore, and that got things working again. Now, when I launch Visual Studio, I get the following message from Git Version control

Opening repository: C:\Workspace\Dev\

This path is the path for where my source code is situated.

Can you please think of what could be messing up Git-Visual Studio integration so abruptly?

P.S. I am on VS 2013, so I did not install any external Git extensions, I am using the one that comes with VS 2013. This exact same problem has happened twice now. On both occsassions, I had to do a system restore to get things working back again.

10

Don't know if it's gonna help you but I was just having this problem myself. All I did was to, in Visual Studio, open Tools -> Options -> Source Control -> Plug-in Selection and change from Microsoft Git Provider to Visual Studio Team Foundation Server, click OK, then go back there and change it back to Microsoft Git Provider.

The message went away after that and I now see the little "locks" back again in source explorer (for unchanged files).

  • That fixed it for me, I had essentially the same symptoms- everything had been working for a year, then suddenly, the project was the r-click|source control menu, but the individual files didn't and none of the source control icons (ie- the lock) were there. – dethSwatch Oct 13 '15 at 17:17
2

Go to Team Explorer, then Connect to Team projects, choose anyone of the projects, and restart VS

  • +1, probably other things contributed, but this final step fixed the problem. – Yishai Jun 27 '16 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.