10

I recently updated my Windows 7 computer with NotePad++ ver. 6.6.9. To do the update I had to run it as Administrator. Now, every time I run Notepad++, it wants to run as Administrator or not at all. I have checked the shortcuts and they are not marked to "Run as Administrator". The problem with this is that NotePad++ can't "see" any of my mapped drives. This is very annoying. How can I get NotePad++ to open normally?

  • 1
    Uninstall it then install it as the Administrator and confugure it to be ran by any user – Ramhound Oct 22 '14 at 17:00
  • 1
    Tried that. At no point does it give me that option. Where would I configure it? – OldDog Oct 23 '14 at 18:46
  • Same problem for me. I've tried: 1) unchecking Run as Admin, 2) superuser.com/questions/547810 (Troubleshoot Compatibility), 3) running in Win 7 compatibility mode as suggested here, and 4) uninstalling and re-installing NP++. The problem first occurred when I started the NP++ installer but didn't run it as admin. After the installation failed Windows asked me if I wanted to re-run as admin and I said yes. Then it installed with this problem. – Samuel Sep 17 '15 at 20:44
7

I have the same problem after upgrade to NPP 6.9.9, and this fix resolved the issue for me:

Right-click on notepad++.exe, Properties, Compatability. Uncheck "Run this program as an administrator". You may need administrator privileges to be able to do this.

  • 1
    this is not working for me – userJT Nov 3 '16 at 20:58
  • Already unchecked. Problem still exists. – HackSlash Apr 12 '18 at 15:34
  • if your notepad was pinned on your taskbar -as me-, this solution also works there. – Asqan May 28 '18 at 3:37
0

I had the same problem when I tried to right-click on the shortcut to notepad++.exe. The shortcut did not have the 'run as administrator' checked, so you cannot 'uncheck' it. However, the target which is the .exe file to which the shortcut points had 'run as administrator' checked. Unchecking it on the the "Compatibility" tab after right-clicking on the filename solved my problem.

  • 1
    Nope. Neither are checked. – HackSlash Apr 12 '18 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.