-1

I had a perfectly good triple-boot laptop running MacOS 10.6.8 (Snow Leopard, 32-bit), Windows 7 (32-bit), and Ubuntu (12.10? 32-bit, anyway). Apple's ads persuaded me that I should take the free upgrade to Yosemite. That started a nightmare.

First I had to do the download about 5 times (times 5 GB!!) because I kept getting "validation errors" on the download. Then the upgrade claimed that it could not install it on my hard drive because "the drive is locked". So I installed it on a USB stick instead. The install to the USB stick took over 10 hours. When I rebooted it later with the USB stick unplugged (thinking it would now boot Snow Leopard from my hard drive), it booted into the upgrade and eventually came up in OS X Yosemite. But at that point, it did not offer Windows or Ubuntu as boot options.

I figured it had wiped out (or lost contact with) rEFIt, so I refreshed it by installing rEFInd. After that, the rEFInd boot menu showed all three operating systems, but only OS X will boot.

After two days of research, I am beginning to think that the problem is that 32-bit and 64-bit OS-es cannot coexist on the platform.

Am I going to have to find a way back to Snow Leopard to get my triple-boot back? Or is there a magic stanza I can put in the rEFInd boot configuration file to make this work?

  • If your os x was 32-bit then if you performed an upgrade its still 32-bit – Ramhound Oct 22 '14 at 17:13
  • @Ramhound OS X has been dual-architecture for ages now. Whether the 32 or 64 bit kernel boots depends entire on what the user chooses or the hardware (the question is missing this) is capable of. /edit: Well, it seems after 10.7 there’s no more 32-bit mode. – Daniel B Oct 22 '14 at 17:26
  • Yes; I know both exist or did exist but even os x cannot upgrade a 32-bit version to 64-bit version irrespective of the Bootloader bitness – Ramhound Oct 22 '14 at 17:56
  • Why wouldn’t it? It obviously worked. Not being able to upgrade Windows x86 to x64 is purely a design choice. – Daniel B Oct 23 '14 at 5:25
0

Anecdotally [ie, I can't find an official declaration as such] Yosemite doesn't support Win 7 in Bootcamp, only Win 8.

It hasn't supported 32-bit Win for quite some time, unless you have a non-64-bit OS... which I guess you did until recently.

Nix, I've never tried.

ref, non-authoratitive: http://forums.appleinsider.com/t/165559/apple-ends-windows-7-support-in-boot-camp-for-new-mac-pro

0

The problem turned out to be simple: The Yosemite upgrade had overwritten the "fake" MBR partition table with a new one which did not contain the existing windows and Ubuntu partitions.

The solution: 1) Boot into the rEFInd command shell 2) Execute the command gptsync_x64.efi 3) Answer the questions with a Y: (paraphrased) the partition tables do not match, would you like to see what it would like like if I fixed it? and would you like me to fix it?

I then rebooted and everything is good.

For those who claimed that OSX is available in 32-bit and 64-bit: Not any more. Going forward, it is 64-bit only, and the early Intel-Macs cannot run systems later than Lion. But the 64-bit EFI boots 32-bit OS-es jsut fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.