6

I recently attached two high DPI displays to my Windows 8.1 desktop PC. As a result I put the scaling (found at Screen Resolution > Make text ... larger or smaller) to 200%.

This has been an adventure, with some things working well and other things working poorly.

But one thing is really disrupting my routine: When I try to remote desktop into this PC from my Windows 7 laptop, everything is HUGE, to the point of being almost unusable. Please see

enter image description here

for comic effect.

Googling around has revealed a lot of people with the reverse problem -- Remoting into legacy systems from a client with a high DPI display. The suggested solution there is to use Remote Desktop Connection Manager. I tried this and can't find any settings that fix my problem.

I am also prevented by remote desktop from turning the scaling off remotely, so even that is not viable as a workaround.

Is there a way to escape this 'kids mode', and just have the remote show at normal 100% zoom?

mstsc.exe on the Windows 7 client is version 6.1.7601.17514. I tried installing the RDP 8.0 update for Windows 7 but this did not appear to make any noticeable difference.

update:

per cdavid's suggestion I updated my RDP on the Windows 7 client with http://support.microsoft.com/kb/2830477 mstsc.exe now shows version 6.1.7601.18540.

But it doesn't seem to matter in my case.. everything is still huge.

I logged off (with a shutdown -l) and back in several times. I have tried setting my client to my native resolution, fullscreen, and fullscreen+all monitors, all checks under experience are selected.

  • RE RDCM: "go to the 'Remote Desktop Settings' tab of the Properties and select 'Same as client area'" Is that option not there for you? – Ƭᴇcʜιᴇ007 Oct 22 '14 at 19:49
  • Same as client area is a displayed option, but selecting it does not change my issue, unfortunately. – Jim Noble Oct 22 '14 at 19:56
  • Just for the sake of information -- What version of the RDP client are you using on the Windows 7 machine? – Ƭᴇcʜιᴇ007 Oct 22 '14 at 20:11
1

RDP 8.1 (latest version) attempts to do DPI-scaling redirection (match the DPI on the server side with the DPI on the client side). This only works if the session that is started on the server side is a new session. Why? Unfortunately, DWM (window manager) and explorer can not change the DPI dynamically (it requires a logout).

So, the "solution" that you can try is to log in, open CMD, run logout, wait until it logs you out and then attempt an MSTSC connection again. This should give you a new session and once MSTSC connects to the machine, it will "remote" the DPI settings, thus making things look normal.

There are cons to this:

  • you lose your existing session
  • it takes time to do this
  • when you will login locally to the server, everything will be tiny :) (because the DPI settings persist - so you will have to login again :( )
  • FYI - things got better with Windows 10 - the DPI scaling happens on the fly for most of the UI elements. – cdavid Sep 27 '15 at 9:39
0

The most up to date info on scaling/zooming and remote desktop is in this response: https://superuser.com/a/1031862/15466

protected by Community Jul 12 '18 at 14:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.